summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-12 22:43:45 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-12 22:43:45 +0000
commitb1547415e896e2a4cfa3fc94203e0ef579571a9b (patch)
tree20353f614f93fe2e12a836984fede2848f47848b /games-emulation
parentVersion bump by Ben Kohler (bug #455172). (diff)
downloadgentoo-2-b1547415e896e2a4cfa3fc94203e0ef579571a9b.tar.gz
gentoo-2-b1547415e896e2a4cfa3fc94203e0ef579571a9b.tar.bz2
gentoo-2-b1547415e896e2a4cfa3fc94203e0ef579571a9b.zip
cosmetic fix, make the sed apply for missing leading whitespaces too
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/sdlmame/ChangeLog6
-rw-r--r--games-emulation/sdlmame/sdlmame-0.148_p1.ebuild6
2 files changed, 7 insertions, 5 deletions
diff --git a/games-emulation/sdlmame/ChangeLog b/games-emulation/sdlmame/ChangeLog
index 165498b2a94c..6fc3681ddd26 100644
--- a/games-emulation/sdlmame/ChangeLog
+++ b/games-emulation/sdlmame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/sdlmame
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/ChangeLog,v 1.60 2013/02/12 22:23:06 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/ChangeLog,v 1.61 2013/02/12 22:43:45 hasufell Exp $
+
+ 12 Feb 2013; Julian Ospald <hasufell@gentoo.org> sdlmame-0.148_p1.ebuild:
+ cosmetic fix, make the sed apply for missing leading whitespaces too
12 Feb 2013; Julian Ospald <hasufell@gentoo.org> sdlmame-0.148_p1.ebuild:
fontconfig is unconditional, fix alsa-sed
@@ -297,4 +300,3 @@
+files/mame.ini.in, +files/vector.ini, +metadata.xml,
+sdlmame-0.124.ebuild, +sdlmame-0.124_p3.ebuild:
Initial release
-
diff --git a/games-emulation/sdlmame/sdlmame-0.148_p1.ebuild b/games-emulation/sdlmame/sdlmame-0.148_p1.ebuild
index 05d7848a6c7a..eed6b609fc9b 100644
--- a/games-emulation/sdlmame/sdlmame-0.148_p1.ebuild
+++ b/games-emulation/sdlmame/sdlmame-0.148_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/sdlmame-0.148_p1.ebuild,v 1.3 2013/02/12 22:23:06 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/sdlmame-0.148_p1.ebuild,v 1.4 2013/02/12 22:43:45 hasufell Exp $
EAPI=5
PYTHON_COMPAT=( python2_6 python2_7 )
@@ -60,7 +60,7 @@ disable_feature() {
# Function to enable a makefile option
enable_feature() {
sed -i \
- -e "/^#.*$1.*=/s:^# ::" \
+ -e "/^#.*$1.*=/s:^#::" \
"${S}"/${2:-makefile} \
|| die "sed failed"
}
@@ -117,7 +117,7 @@ src_prepare() {
if ! use alsa ; then
einfo "Disabling alsa midi support"
- sed -i -e "/^#NO_USE_MIDI.*=/s:^#::" src/osd/sdl/sdl.mak || die
+ enable_feature NO_USE_MIDI src/osd/sdl/sdl.mak
fi
if ! use X ; then