summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-05-31 14:58:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-05-31 14:58:07 +0000
commit6e01a03e8e50a92dbab366ab05de504137f12b50 (patch)
tree081cb3a2b04d85bd29261c5e120004232db11ae4 /games-emulation/stella
parentUpdate dependencies (diff)
downloadgentoo-2-6e01a03e8e50a92dbab366ab05de504137f12b50.tar.gz
gentoo-2-6e01a03e8e50a92dbab366ab05de504137f12b50.tar.bz2
gentoo-2-6e01a03e8e50a92dbab366ab05de504137f12b50.zip
version bump
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-emulation/stella')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/stella-3.4.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index cbe07acdaeb0..27c9051111c5 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.60 2011/01/15 15:08:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.61 2011/05/31 14:58:07 mr_bones_ Exp $
+
+*stella-3.4 (31 May 2011)
+
+ 31 May 2011; Michael Sterrett <mr_bones_@gentoo.org> +stella-3.4.ebuild:
+ Version bump
15 Jan 2011; Markus Meier <maekke@gentoo.org> stella-3.3.ebuild:
x86 stable, bug #350772
diff --git a/games-emulation/stella/stella-3.4.ebuild b/games-emulation/stella/stella-3.4.ebuild
new file mode 100644
index 000000000000..243a6e59ea4a
--- /dev/null
+++ b/games-emulation/stella/stella-3.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.4.ebuild,v 1.1 2011/05/31 14:58:07 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="joystick opengl"
+
+DEPEND="media-libs/libsdl[joystick?,video]
+ x11-libs/libX11
+ media-libs/libpng
+ sys-libs/zlib
+ opengl? ( virtual/opengl )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.png
+ make_desktop_entry stella Stella
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}