summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-07 06:02:13 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-07 06:02:13 +0000
commit8deb7760bfc7b635c35e95f47e5c851c4811acd2 (patch)
tree476694a894631fb58b3afd5d420819d96f2d668a /games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild
parentVersion bump in response to bug #69722 (Manifest recommit) (diff)
downloadgentoo-2-8deb7760bfc7b635c35e95f47e5c851c4811acd2.tar.gz
gentoo-2-8deb7760bfc7b635c35e95f47e5c851c4811acd2.tar.bz2
gentoo-2-8deb7760bfc7b635c35e95f47e5c851c4811acd2.zip
Version bump.
Diffstat (limited to 'games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild')
-rw-r--r--games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild b/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild
new file mode 100644
index 000000000000..84b613faec82
--- /dev/null
+++ b/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild,v 1.1 2004/12/07 06:02:13 vapier Exp $
+
+inherit eutils games
+
+DESCRIPTION="P.E.Op.S Sound Emulation (SPU) PSEmu Plugin"
+HOMEPAGE="http://sourceforge.net/projects/peops/"
+SRC_URI="mirror://sourceforge/peops/PeopsSpu${PV//./}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE="alsa oss"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ app-arch/unzip
+ =x11-libs/gtk+-1*"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-devel/automake"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd src
+ sed -i \
+ -e "s:-mpentium -O3 -ffast-math -fomit-frame-pointer:${CFLAGS}:" \
+ Makefile \
+ || die "sed Makefile failed"
+
+ cd linuxcfg
+ tar -zxf spucfg.tar.gz || die "unpack linuxcfg"
+ make maintainer-clean || die "distclean linuxcfg"
+ rm -f {,src/}Makefile.in aclocal.m4 configure
+ edos2unix `find -name '*.[ch]'` *.in
+ aclocal && automake -a -c && autoconf || die "could not autotool"
+}
+
+src_compile() {
+ cd src
+ if use oss || ! use alsa; then
+ make clean || die "oss clean"
+ emake USEALSA=FALSE || die "oss build"
+ mv libspu* ..
+ fi
+ if use alsa ; then
+ make clean || die "alsa clean"
+ emake USEALSA=TRUE || die "alsa build"
+ mv libspu* ..
+ fi
+
+ cd linuxcfg
+ econf || die
+ emake || die "linuxcfg failed"
+ mv src/spucfg src/cfgPeopsOSS
+}
+
+src_install() {
+ exeinto ${GAMES_LIBDIR}/psemu/plugins
+ doexe libspu* || die "doexe plugins"
+ exeinto ${GAMES_LIBDIR}/psemu/cfg
+ doexe cfgPeopsOSS || die "doexe cfg"
+ insinto ${GAMES_LIBDIR}/psemu/cfg
+ doins spuPeopsOSS.cfg
+ dodoc src/*.txt *.txt
+ prepgamesdirs
+}