summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-02-14 01:42:44 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-02-14 01:42:44 +0000
commit7840d7278690f3de4acd0ed9996974e7a74ebf59 (patch)
treec7eca44505a80885da405e3870f9c0c13413036a /games-emulation/lxdream
parentRevision bump for new genpatches. (diff)
downloadgentoo-2-7840d7278690f3de4acd0ed9996974e7a74ebf59.tar.gz
gentoo-2-7840d7278690f3de4acd0ed9996974e7a74ebf59.tar.bz2
gentoo-2-7840d7278690f3de4acd0ed9996974e7a74ebf59.zip
commit improved ebuild thanks to mr_bones_ and abcd
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/lxdream')
-rw-r--r--games-emulation/lxdream/ChangeLog8
-rw-r--r--games-emulation/lxdream/lxdream-0.9.1-r1.ebuild (renamed from games-emulation/lxdream/lxdream-0.9.1.ebuild)33
2 files changed, 30 insertions, 11 deletions
diff --git a/games-emulation/lxdream/ChangeLog b/games-emulation/lxdream/ChangeLog
index 979b77bc990f..cbbcf19e2860 100644
--- a/games-emulation/lxdream/ChangeLog
+++ b/games-emulation/lxdream/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/lxdream
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/lxdream/ChangeLog,v 1.1 2010/02/13 23:33:02 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/lxdream/ChangeLog,v 1.2 2010/02/14 01:42:44 chithanh Exp $
+
+*lxdream-0.9.1-r1 (14 Feb 2010)
+
+ 14 Feb 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ -lxdream-0.9.1.ebuild, +lxdream-0.9.1-r1.ebuild:
+ commit improved version thanks to mr_bones_ and abcd
*lxdream-0.9.1 (13 Feb 2010)
diff --git a/games-emulation/lxdream/lxdream-0.9.1.ebuild b/games-emulation/lxdream/lxdream-0.9.1-r1.ebuild
index 1382baae8e8f..5ae5b0481583 100644
--- a/games-emulation/lxdream/lxdream-0.9.1.ebuild
+++ b/games-emulation/lxdream/lxdream-0.9.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/lxdream/lxdream-0.9.1.ebuild,v 1.1 2010/02/13 23:33:02 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/lxdream/lxdream-0.9.1-r1.ebuild,v 1.1 2010/02/14 01:42:44 chithanh Exp $
-EAPI="2"
+EAPI=2
inherit eutils games
@@ -13,13 +13,12 @@ SRC_URI="http://www.lxdream.org/count.php?file=${P}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug esd profile pulseaudio sdl"
+IUSE="debug profile pulseaudio sdl"
RDEPEND="media-libs/alsa-lib
media-libs/libpng
- esd? ( media-sound/esound )
pulseaudio? ( media-sound/pulseaudio )
- sdl? ( media-libs/libsdl )
+ sdl? ( media-libs/libsdl[audio] )
virtual/opengl
x11-libs/gtk+:2"
@@ -28,20 +27,34 @@ DEPEND="${RDEPEND}
sys-devel/gettext
virtual/os-headers"
+src_prepare() {
+ # Make .desktop file pass desktop-file-validate
+ sed -i \
+ -e '/Encoding/d' \
+ -e '/FilePattern/d' \
+ -e '/Categories/s|$|;|' \
+ ${PN}.desktop || die "sed failed"
+ # Do not override user-specified CFLAGS
+ sed -i \
+ -e s/'CFLAGS=\"-g -fexceptions\"'/'CFLAGS=\"${CFLAGS} -g -fexceptions\"'/ \
+ -e '/CCOPT/d' \
+ -e '/OBJCOPT/d' \
+ configure || die "sed failed"
+}
+
src_configure() {
- econf \
+ egamesconf \
+ --datadir="${GAMES_DATADIR_BASE}" \
$(use_enable debug trace) \
$(use_enable debug watch) \
$(use_enable profile profiled) \
- $(use_with esd) \
$(use_with pulseaudio pulse) \
- $(use_with sdl)
+ $(use_with sdl) \
+ --without-esd
}
src_install() {
emake DESTDIR="${D}" install || die "install failed"
dodoc ChangeLog NEWS README || die "dodoc failed"
- doicon pixmaps/${PN}.png || die "doicon failed"
- domenu ${PN}.desktop || die "domenu failed"
prepgamesdirs
}