summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-03-21 16:42:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-03-21 16:42:04 +0000
commit5efabaecaacd2962644fd41e09627b905202bba0 (patch)
tree08c205450f0097999e2e5c2131984e5a711d55ed /games-emulation/hatari
parent*sigh* (diff)
downloadgentoo-2-5efabaecaacd2962644fd41e09627b905202bba0.tar.gz
gentoo-2-5efabaecaacd2962644fd41e09627b905202bba0.tar.bz2
gentoo-2-5efabaecaacd2962644fd41e09627b905202bba0.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-emulation/hatari')
-rw-r--r--games-emulation/hatari/ChangeLog9
-rw-r--r--games-emulation/hatari/hatari-1.0.0.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
index 87e29fc3d8b5..9ffa6f977cf3 100644
--- a/games-emulation/hatari/ChangeLog
+++ b/games-emulation/hatari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/hatari
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.16 2007/08/07 18:47:53 mr_bones_ Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.17 2008/03/21 16:42:04 mr_bones_ Exp $
+
+*hatari-1.0.0 (21 Mar 2008)
+
+ 21 Mar 2008; Michael Sterrett <mr_bones_@gentoo.org> +hatari-1.0.0.ebuild:
+ version bump
*hatari-0.95 (07 Aug 2007)
diff --git a/games-emulation/hatari/hatari-1.0.0.ebuild b/games-emulation/hatari/hatari-1.0.0.ebuild
new file mode 100644
index 000000000000..00360045b6c4
--- /dev/null
+++ b/games-emulation/hatari/hatari-1.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-1.0.0.ebuild,v 1.1 2008/03/21 16:42:04 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ sys-libs/readline
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ games-emulation/emutos"
+
+src_compile() {
+ egamesconf || die
+ # broken deps in the makefiles - bug #164068
+ emake -C src/uae-cpu gencpu || die "emake failed"
+ emake -C src/uae-cpu all || die "emake failed"
+ emake -C src || die "emake failed"
+}
+
+src_install() {
+ dogamesbin "${S}/src/hatari" || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins src/gui-sdl/font5x8.bmp src/gui-sdl/font10x16.bmp \
+ || die "doins failed"
+ dodoc readme.txt doc/*.txt
+ dohtml -r doc/
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
+ elog "has been installed in $(games_get_libdir) with a .img extension (there"
+ elog "are several from which to choose)."
+ elog
+ elog "Another option is to go to http://www.atari.st/ and get a real TOS:"
+ elog " http://www.atari.st/"
+ elog
+ elog "The first time you run hatari, you should configure it to find the"
+ elog "TOS you prefer to use. Be sure to save your settings."
+ echo
+}