summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-06-14 15:34:07 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-06-14 15:34:07 +0000
commite040d697ecbad444109e18c48c19b5e3aa0861dc (patch)
tree31faae2c28c72a41d9516d966ded469b3b5f8fdd /games-emulation/gngeo/gngeo-0.7.ebuild
parentBug #226505 - For compatibility with phase execution order in (diff)
downloadgentoo-2-e040d697ecbad444109e18c48c19b5e3aa0861dc.tar.gz
gentoo-2-e040d697ecbad444109e18c48c19b5e3aa0861dc.tar.bz2
gentoo-2-e040d697ecbad444109e18c48c19b5e3aa0861dc.zip
Ensure we do not use i386 asm on amd64, fixes #222149.
(Portage version: 2.2_pre8/cvs/Linux 2.6.25-gentoo-r3 x86_64)
Diffstat (limited to 'games-emulation/gngeo/gngeo-0.7.ebuild')
-rw-r--r--games-emulation/gngeo/gngeo-0.7.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/games-emulation/gngeo/gngeo-0.7.ebuild b/games-emulation/gngeo/gngeo-0.7.ebuild
index 66db03610f19..81f7ff38d428 100644
--- a/games-emulation/gngeo/gngeo-0.7.ebuild
+++ b/games-emulation/gngeo/gngeo-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/gngeo-0.7.ebuild,v 1.4 2007/02/07 13:51:06 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/gngeo-0.7.ebuild,v 1.5 2008/06/14 15:34:07 coldwind Exp $
inherit eutils autotools games
@@ -29,6 +29,11 @@ src_unpack() {
eautoreconf
}
+src_compile() {
+ egamesconf $(use_enable x86 i386asm) || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS FAQ NEWS README* TODO sample_gngeorc