summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-28 12:46:57 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-28 12:46:57 +0000
commit802b4443072a13617bfd4c7a78f2b953786a23d4 (patch)
treee41fb01fd2685952af1557e90a25eaf47169fc30 /games-emulation/gngb
parentVersion bump (diff)
downloadgentoo-2-802b4443072a13617bfd4c7a78f2b953786a23d4.tar.gz
gentoo-2-802b4443072a13617bfd4c7a78f2b953786a23d4.tar.bz2
gentoo-2-802b4443072a13617bfd4c7a78f2b953786a23d4.zip
Fix gcc-4.5 overflow warning. Bug #340196
(Portage version: 2.1.9.22/cvs/Linux i686)
Diffstat (limited to 'games-emulation/gngb')
-rw-r--r--games-emulation/gngb/ChangeLog6
-rw-r--r--games-emulation/gngb/files/gngb-20060309-ovflfix.patch17
-rw-r--r--games-emulation/gngb/gngb-20060309.ebuild7
3 files changed, 27 insertions, 3 deletions
diff --git a/games-emulation/gngb/ChangeLog b/games-emulation/gngb/ChangeLog
index de0c7013cac0..1ee8eccf93c4 100644
--- a/games-emulation/gngb/ChangeLog
+++ b/games-emulation/gngb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/gngb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/ChangeLog,v 1.14 2010/10/15 12:32:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/ChangeLog,v 1.15 2010/10/28 12:46:57 tupone Exp $
+
+ 28 Oct 2010; Tupone Alfredo <tupone@gentoo.org> gngb-20060309.ebuild,
+ +files/gngb-20060309-ovflfix.patch:
+ Fix gcc-4.5 overflow warning. Bug #340196 by flameeyes@gentoo.org
15 Oct 2010; Brent Baude <ranger@gentoo.org> gngb-20060309.ebuild:
stable ppc, bug 313789
diff --git a/games-emulation/gngb/files/gngb-20060309-ovflfix.patch b/games-emulation/gngb/files/gngb-20060309-ovflfix.patch
new file mode 100644
index 000000000000..d4cad523854e
--- /dev/null
+++ b/games-emulation/gngb/files/gngb-20060309-ovflfix.patch
@@ -0,0 +1,17 @@
+--- src/serial.c.old 2010-10-28 14:40:23.000000000 +0200
++++ src/serial.c 2010-10-28 14:41:07.000000000 +0200
+@@ -302,11 +302,11 @@
+ /* Gbserial_read: Read a byte on the serial
+ This is a block function */
+ Uint8 gbserial_read(void) {
+- Uint8 b;
++ Uint8 b[2];
+
+ gbserial.ready2read=0;
+- if ((read(dest_socket,&b,2))<=0) return 0xFF;
+- return b;
++ if ((read(dest_socket,b,2))<=0) return 0xFF;
++ return b[0];
+ }
+
+ /* Gbserial_write: Write a byte on the serial
diff --git a/games-emulation/gngb/gngb-20060309.ebuild b/games-emulation/gngb/gngb-20060309.ebuild
index 2e2e8dfc23e7..68fc9d12468c 100644
--- a/games-emulation/gngb/gngb-20060309.ebuild
+++ b/games-emulation/gngb/gngb-20060309.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/gngb-20060309.ebuild,v 1.6 2010/10/15 12:32:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/gngb-20060309.ebuild,v 1.7 2010/10/28 12:46:57 tupone Exp $
EAPI=2
inherit eutils games
@@ -14,10 +14,13 @@ SLOT="0"
KEYWORDS="ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="opengl"
-DEPEND="media-libs/libsdl[audio,joystick,video]
+RDEPEND="media-libs/libsdl[audio,joystick,video]
sys-libs/zlib
app-arch/bzip2
opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ovflfix.patch )
src_configure() {
egamesconf $(use_with opengl gl)