summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-23 21:39:23 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-23 21:39:23 +0000
commit8ec75bbc2293d1bc69a61df42c790dc98b3832fb (patch)
treeebd191c0db2699bca3debafd28294c3c1466eda1 /games-emulation/atari800
parentstable on amd64 (diff)
downloadgentoo-2-8ec75bbc2293d1bc69a61df42c790dc98b3832fb.tar.gz
gentoo-2-8ec75bbc2293d1bc69a61df42c790dc98b3832fb.tar.bz2
gentoo-2-8ec75bbc2293d1bc69a61df42c790dc98b3832fb.zip
Fix hardcoded paths
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'games-emulation/atari800')
-rw-r--r--games-emulation/atari800/ChangeLog5
-rw-r--r--games-emulation/atari800/atari800-2.0.2.ebuild68
2 files changed, 38 insertions, 35 deletions
diff --git a/games-emulation/atari800/ChangeLog b/games-emulation/atari800/ChangeLog
index 6fb59418982a..4bfcef238117 100644
--- a/games-emulation/atari800/ChangeLog
+++ b/games-emulation/atari800/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/atari800
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/ChangeLog,v 1.17 2006/11/22 15:55:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/ChangeLog,v 1.18 2006/11/23 21:39:23 nyhm Exp $
+
+ 23 Nov 2006; Tristan Heaven <nyhm@gentoo.org> atari800-2.0.2.ebuild:
+ Fix hardcoded paths
22 Nov 2006; Joseph Jezak <josejx@gentoo.org> atari800-2.0.2.ebuild:
Marked ppc stable for bug #153645.
diff --git a/games-emulation/atari800/atari800-2.0.2.ebuild b/games-emulation/atari800/atari800-2.0.2.ebuild
index 3f2ffd3ecf6c..d35fbedbe720 100644
--- a/games-emulation/atari800/atari800-2.0.2.ebuild
+++ b/games-emulation/atari800/atari800-2.0.2.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/atari800-2.0.2.ebuild,v 1.4 2006/11/22 15:55:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/atari800-2.0.2.ebuild,v 1.5 2006/11/23 21:39:23 nyhm Exp $
inherit games
DESCRIPTION="Atari 800 emulator"
HOMEPAGE="http://atari800.sourceforge.net/"
-SRC_URI="mirror://sourceforge/atari800/${P}.tar.gz
- mirror://sourceforge/atari800/xf25.zip"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/xf25.zip"
-LICENSE="GPL-1"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ppc sparc x86"
IUSE="sdl"
RDEPEND="sdl? ( >=media-libs/libsdl-1.2.0 )
- !sdl? ( || ( ( x11-libs/libX11 ) virtual/x11 ) )"
+ !sdl? ( x11-libs/libX11 )"
DEPEND="${RDEPEND}
!sdl? (
- || (
- ( x11-libs/libXt
- x11-libs/libX11
- x11-proto/xextproto
- x11-proto/xproto )
- virtual/x11 ) )
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-proto/xextproto
+ x11-proto/xproto )
app-arch/unzip"
src_unpack() {
@@ -31,6 +29,8 @@ src_unpack() {
cd "${S}"
# remove some not-so-interesting ones
rm -f DOC/{INSTALL.*,*.in,CHANGES.OLD}
+ sed -i "/CFG_FILE/s:/etc:${GAMES_SYSCONFDIR}:" \
+ src/atari.c || die "sed failed"
}
src_compile() {
@@ -60,8 +60,11 @@ src_install () {
dodoc README.1ST DOC/*
insinto "${GAMES_DATADIR}/${PN}"
doins "${WORKDIR}/"*.ROM || die "doins failed (ROM)"
- insinto /etc
- doins "${FILESDIR}/atari800.cfg" || die "doins failed (cfg)"
+ sed "s:/usr/share/games:${GAMES_DATADIR}:" \
+ "${FILESDIR}"/atari800.cfg > "${T}"/atari800.cfg \
+ || die "sed failed"
+ insinto "${GAMES_SYSCONFDIR}"
+ doins "${T}"/atari800.cfg || die "doins failed (cfg)"
prepgamesdirs
}
@@ -69,30 +72,27 @@ pkg_postinst() {
games_pkg_postinst
if use sdl ; then
echo
+ elog 'The emulator has been compiled using the SDL libraries. By default,'
+ elog 'atari800 switches to fullscreen mode, so a 400x300 entry in your'
+ elog 'XF86Config-4 file is recommended. Otherwise, the emulated Atari'
+ elog 'screen is postage-stamp sized in the middle of your display.'
echo
- einfo 'The emulator has been compiled using the SDL libraries. By default,'
- einfo 'atari800 switches to fullscreen mode, so a 400x300 entry in your'
- einfo 'XF86Config-4 file is recommended. Otherwise, the emulated Atari'
- einfo 'screen is postage-stamp sized in the middle of your display.'
- echo
- einfo 'For example, in the "Screen" section of your /etc/XF86Config-4 file,'
- einfo 'add the entry "400x300" to the end of the list of modes:'
- echo
- einfo ' Section "Screen"'
- einfo ' [...]'
- einfo
- einfo ' Subsection "Display"'
- einfo ' Depth 16'
- einfo ' Modes "1600x1200" "1024x768" "400x300"'
- einfo ' ViewPort 0 0'
- einfo ' EndSubsection'
- einfo ' EndSection'
- echo
- einfo 'You should not need to specify a modeline for this mode,'
- einfo 'since in most cases it is a standard mode calculated by'
- einfo 'the X server.'
+ elog 'For example, in the "Screen" section of your /etc/XF86Config-4 file,'
+ elog 'add the entry "400x300" to the end of the list of modes:'
echo
+ elog ' Section "Screen"'
+ elog ' [...]'
+ elog
+ elog ' Subsection "Display"'
+ elog ' Depth 16'
+ elog ' Modes "1600x1200" "1024x768" "400x300"'
+ elog ' ViewPort 0 0'
+ elog ' EndSubsection'
+ elog ' EndSection'
echo
+ elog 'You should not need to specify a modeline for this mode,'
+ elog 'since in most cases it is a standard mode calculated by'
+ elog 'the X server.'
echo
fi
}