summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-12-05 16:19:25 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-12-05 16:19:25 +0000
commit5b253ec9022c933164886a29de504872852e16d9 (patch)
tree53a041812d39e88fcc326c9896ffcbab188472c9 /games-emulation/advancemame
parentVersion bump (diff)
downloadgentoo-2-5b253ec9022c933164886a29de504872852e16d9.tar.gz
gentoo-2-5b253ec9022c933164886a29de504872852e16d9.tar.bz2
gentoo-2-5b253ec9022c933164886a29de504872852e16d9.zip
Remove expat and zlib USE flags, bug #249459
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'games-emulation/advancemame')
-rw-r--r--games-emulation/advancemame/ChangeLog5
-rw-r--r--games-emulation/advancemame/advancemame-0.106.0.ebuild11
2 files changed, 9 insertions, 7 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 4d0dd31b140c..acf3610d66b5 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.45 2008/03/10 18:09:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.46 2008/12/05 16:19:25 nyhm Exp $
+
+ 05 Dec 2008; Tristan Heaven <nyhm@gentoo.org> advancemame-0.106.0.ebuild:
+ Remove expat and zlib USE flags, bug #249459
10 Mar 2008; Michael Sterrett <mr_bones_@gentoo.org>
advancemame-0.106.0.ebuild:
diff --git a/games-emulation/advancemame/advancemame-0.106.0.ebuild b/games-emulation/advancemame/advancemame-0.106.0.ebuild
index 2040055efa49..281b4700ac24 100644
--- a/games-emulation/advancemame/advancemame-0.106.0.ebuild
+++ b/games-emulation/advancemame/advancemame-0.106.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.106.0.ebuild,v 1.6 2008/03/10 18:09:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.106.0.ebuild,v 1.7 2008/12/05 16:19:25 nyhm Exp $
inherit eutils flag-o-matic games
@@ -11,15 +11,14 @@ SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
LICENSE="GPL-2 XMAME"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
-IUSE="alsa expat fbcon oss sdl static svga truetype zlib"
+IUSE="alsa fbcon oss sdl static svga truetype"
# sdl is required (bug #158417)
RDEPEND="app-arch/unzip
app-arch/zip
media-libs/libsdl
+ dev-libs/expat
alsa? ( media-libs/alsa-lib )
- expat? ( >=dev-libs/expat-1.95.6 )
- zlib? ( sys-libs/zlib )
truetype? ( media-libs/freetype )
svga? ( >=media-libs/svgalib-1.9 )"
DEPEND="${RDEPEND}
@@ -51,16 +50,16 @@ src_compile() {
PATH="${PATH}:${T}"
egamesconf \
+ --enable-expat \
--enable-sdl \
+ --enable-zlib \
--disable-slang \
$(use_enable alsa) \
- $(use_enable expat) \
$(use_enable fbcon fb) \
$(use_enable oss) \
$(use_enable static) \
$(use_enable svga svgalib) \
$(use_enable truetype freetype) \
- $(use_enable zlib) \
$(use_enable x86 asm) \
--with-emu=${PN/advance} \
|| die