summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-24 01:04:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-24 01:04:09 +0000
commit44e5fef583df87a9988f552419952f4858cb0aec (patch)
treee16a3535a52c7004bd66ae536f586d5a8040c645 /games-board
parentMarked ppc stable. (diff)
downloadgentoo-2-44e5fef583df87a9988f552419952f4858cb0aec.tar.gz
gentoo-2-44e5fef583df87a9988f552419952f4858cb0aec.tar.bz2
gentoo-2-44e5fef583df87a9988f552419952f4858cb0aec.zip
Install the source to fix #81176 by David Ripton and fix an assert error #94234 by Mark Knecht.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pysol/ChangeLog11
-rw-r--r--games-board/pysol/files/digest-pysol-4.82-r12
-rw-r--r--games-board/pysol/files/pysol-4.82-sound-ok.patch22
-rw-r--r--games-board/pysol/pysol-4.82-r1.ebuild54
4 files changed, 87 insertions, 2 deletions
diff --git a/games-board/pysol/ChangeLog b/games-board/pysol/ChangeLog
index 6d1a4a3df9ab..eb3604ce7e00 100644
--- a/games-board/pysol/ChangeLog
+++ b/games-board/pysol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-board/pysol
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pysol/ChangeLog,v 1.6 2005/06/15 18:31:16 wolf31o2 Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pysol/ChangeLog,v 1.7 2005/06/24 01:04:09 vapier Exp $
+
+*pysol-4.82-r1 (24 Jun 2005)
+
+ 24 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/pysol-4.82-sound-ok.patch, +pysol-4.82-r1.ebuild:
+ Install the source to fix #81176 by David Ripton and fix an assert error
+ #94234 by Mark Knecht.
15 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org> pysol-4.82.ebuild:
Removed INSTALL file.
diff --git a/games-board/pysol/files/digest-pysol-4.82-r1 b/games-board/pysol/files/digest-pysol-4.82-r1
new file mode 100644
index 000000000000..b6f4f3d021f3
--- /dev/null
+++ b/games-board/pysol/files/digest-pysol-4.82-r1
@@ -0,0 +1,2 @@
+MD5 31a3ed96c6feb54717c6bce9ddd82b24 pysol-4.82.tar.bz2 3586977
+MD5 be0fd45c016fe2dcacb03fb29871aff4 pysol-4.82-src.tar.bz2 150515
diff --git a/games-board/pysol/files/pysol-4.82-sound-ok.patch b/games-board/pysol/files/pysol-4.82-sound-ok.patch
new file mode 100644
index 000000000000..a6ab2af1cde0
--- /dev/null
+++ b/games-board/pysol/files/pysol-4.82-sound-ok.patch
@@ -0,0 +1,22 @@
+self.app.opt.sound is a boolean value while the
+self.tkopt.sound.set() function expects a 0 or 1.
+
+Small hack since i'm no python ninja.
+
+http://bugs.gentoo.org/94234
+
+--- src/actions.py
++++ src/actions.py
+@@ -753,7 +753,11 @@
+ def mOptSoundDialog(self, *args):
+ if self._cancelDrag(): return
+ d = SoundOptionsDialog(self.top, "Sound settings", self.app)
+- self.tkopt.sound.set(self.app.opt.sound)
++ if self.app.opt.sound:
++ setit = 1
++ else:
++ setit = 0
++ self.tkopt.sound.set(setit)
+
+ def mOptAnimations(self, *args):
+ if self._cancelDrag(): return
diff --git a/games-board/pysol/pysol-4.82-r1.ebuild b/games-board/pysol/pysol-4.82-r1.ebuild
new file mode 100644
index 000000000000..3ef2c2b2e205
--- /dev/null
+++ b/games-board/pysol/pysol-4.82-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pysol/pysol-4.82-r1.ebuild,v 1.1 2005/06/24 01:04:09 vapier Exp $
+
+inherit games python eutils
+
+DESCRIPTION="An exciting collection of more than 200 solitaire card games"
+HOMEPAGE="http://www.pysol.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://www.pysol.org/download/pysol/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/python"
+RDEPEND="virtual/python
+ >=games-board/pysol-sound-server-3.0
+ >=dev-lang/tk-8.0"
+
+pkg_setup() {
+ python_tkinter_exists
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f Makefile data/*.pyc
+ epatch "${FILESDIR}"/${P}-sound-ok.patch #94234
+}
+
+src_install() {
+ insinto "${GAMES_LIBDIR}"/${PN}
+ doins -r src/* || die "src failed"
+ fperms 750 "${GAMES_LIBDIR}"/${PN}/pysol.py
+ games_make_wrapper ${PN} "${GAMES_LIBDIR}"/${PN}/pysol.py
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* || die "data failed"
+
+ make_desktop_entry pysol PySol "${GAMES_DATADIR}"/${PN}/pysol.xpm
+
+ doman pysol.6
+ dodoc NEWS README
+}
+
+pkg_postinst() {
+ python_mod_optimize "${GAMES_LIBDIR}"/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${GAMES_LIBDIR}"/${PN}
+}