summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-05 20:09:33 +0000
committerBen de Groot <yngwin@gentoo.org>2015-02-05 20:09:33 +0000
commitc2034afd9a60b2fc3b7bf70d54a6245ea10cc398 (patch)
tree368e76491f3a960e69ffb2cf3bba0a11178065a3 /games-board/stockfish
parentVersion bump. (diff)
downloadgentoo-2-c2034afd9a60b2fc3b7bf70d54a6245ea10cc398.tar.gz
gentoo-2-c2034afd9a60b2fc3b7bf70d54a6245ea10cc398.tar.bz2
gentoo-2-c2034afd9a60b2fc3b7bf70d54a6245ea10cc398.zip
Initial commit (bug #318337)
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'games-board/stockfish')
-rw-r--r--games-board/stockfish/ChangeLog9
-rw-r--r--games-board/stockfish/Manifest3
-rw-r--r--games-board/stockfish/metadata.xml8
-rw-r--r--games-board/stockfish/stockfish-6.ebuild40
4 files changed, 60 insertions, 0 deletions
diff --git a/games-board/stockfish/ChangeLog b/games-board/stockfish/ChangeLog
new file mode 100644
index 000000000000..304ceb3ed0b7
--- /dev/null
+++ b/games-board/stockfish/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-board/stockfish
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/stockfish/ChangeLog,v 1.1 2015/02/05 20:09:33 yngwin Exp $
+
+*stockfish-6 (05 Feb 2015)
+
+ 05 Feb 2015; Ben de Groot <yngwin@gentoo.org> +metadata.xml,
+ +stockfish-6.ebuild:
+ Initial commit (bug #318337)
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
new file mode 100644
index 000000000000..e694fa58b0ee
--- /dev/null
+++ b/games-board/stockfish/Manifest
@@ -0,0 +1,3 @@
+DIST stockfish-6-src.zip 161183 SHA256 a69a371d3f84338cefde4575669bd930d186b046a10fa5ab0f8d1aed6cb204c3 SHA512 8381b7a8616281629f04c6dc4cbe5a279b06067f7af3faff271461f694122eeba9d83a0c4a295b9064142bcaa3b31eca8139b58eb9441684845aad45888402dc WHIRLPOOL 56672a5730ce1f9adef13b658e960f808a990752b749ab3c658e1dbdd54e81bbee9c32ab91c892cd6f8b91ad4d8fe5bcff2c5d0942616b5dda5e77c196ad5092
+EBUILD stockfish-6.ebuild 923 SHA256 b21d1be406dd31c52129d7ad6193bf0714475b097f929fe51817fd9bfc4c968e SHA512 5ffc787167c56035a730d3bbf2b5ba91a30c3fb5f51eff23cce889266bf764a0194f4952b7bd596ecda77ff6a173ce6d0674d5905f9fb54314f980ec0f326775 WHIRLPOOL 76134fb247ecb4658fbaa2adbd7625ada1fdbcc288d173f8da7f44a3d4c00e697922d7ed030ebafaa9b2ed2a979e8c3d8dd39a590262aa98f9265e8fe4627848
+MISC metadata.xml 237 SHA256 184b645af068016765dbc0fea5dc7ebdac3939bff4c5c3cea4c3a954c36aa515 SHA512 2f439c02f625469233818a0b28dd77a40b82606b1cd9d9bca37412103b9c4f8122cc78cd4d53446ce434b3c0cea12c9c6133d2433c7df869231d129f14ecf867 WHIRLPOOL 422c80f167c97179c1cb022108676f9a41b603f0c8031a709c993563b6c84d661bc6b61a3a0609b1da952efa3f4a44004b2267b9142ac564093a07a99bd5de23
diff --git a/games-board/stockfish/metadata.xml b/games-board/stockfish/metadata.xml
new file mode 100644
index 000000000000..f2b4a5d1d932
--- /dev/null
+++ b/games-board/stockfish/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-board/stockfish/stockfish-6.ebuild b/games-board/stockfish/stockfish-6.ebuild
new file mode 100644
index 000000000000..53a35518c7cf
--- /dev/null
+++ b/games-board/stockfish/stockfish-6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/stockfish/stockfish-6.ebuild,v 1.1 2015/02/05 20:09:33 yngwin Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="The strongest chess engine in the world"
+HOMEPAGE="http://stockfishchess.org/"
+SRC_URI="https://stockfish.s3.amazonaws.com/${P}-src.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${P}-src/src
+
+src_prepare() {
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile
+}
+
+src_compile() {
+ local my_arch
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+
+ emake build ARCH=${my_arch} CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc ../AUTHORS ../Readme.md
+}