summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-15 20:54:55 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-15 20:54:55 +0000
commitd64a728417218b91ee4a3725e859bd949303ef7e (patch)
tree861674281afcc41827eeff5ba1a079bb3929b438 /games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild
parentold (diff)
downloadgentoo-2-d64a728417218b91ee4a3725e859bd949303ef7e.tar.gz
gentoo-2-d64a728417218b91ee4a3725e859bd949303ef7e.tar.bz2
gentoo-2-d64a728417218b91ee4a3725e859bd949303ef7e.zip
Update Debian patch and fix X lib/inc issues #79496.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild')
-rw-r--r--games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild b/games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild
new file mode 100644
index 000000000000..9556cf348bea
--- /dev/null
+++ b/games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/xgalaga-2.0.34-r6.ebuild,v 1.1 2005/05/15 20:54:55 vapier Exp $
+
+inherit eutils games
+
+DEB_VER=30
+DESCRIPTION="Galaga game clone."
+HOMEPAGE="http://rumsey.org/xgal.html"
+SRC_URI="http://http.us.debian.org/debian/pool/main/x/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV}-${DEB_VER}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND="virtual/x11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${P}-xpaths.patch #79496
+ epatch "${WORKDIR}"/${PN}_${PV}-${DEB_VER}.diff
+ sed -i \
+ -e "/LEVELDIR\|SOUNDDIR/ s:prefix:datadir/${PN}:" \
+ -e "/\/scores/ s:prefix:localstatedir/${PN}:" configure \
+ || die "sed configure failed"
+ sed -i \
+ -e '/SOUNDDEFS/ s:@prefix@:@prefix@/bin:' Makefile.in \
+ || die "sed Makefile.in failed"
+}
+
+src_compile() {
+ egamesconf || die
+ emake CPPFLAGS="-D__NO_STRING_INLINES" || die "compile problem"
+}
+
+src_install() {
+ dogamesbin xgalaga xgal.sndsrv.linux || die "dogamesbin failed"
+ dodoc README README.SOUND CHANGES INSTALL
+ newman xgal.6x xgal.6
+
+ insinto "${GAMES_DATADIR}/${PN}/sounds"
+ doins sounds/*.raw || die "doins failed"
+
+ insinto "${GAMES_DATADIR}/${PN}/levels"
+ doins levels/*.xgl || die "doins failed"
+
+ insinto /usr/share/pixmaps
+ doins xgalaga-icon.xpm || die "doins failed"
+
+ make_desktop_entry xgalaga xgalaga xgalaga-icon.xpm
+
+ dodir "${GAMES_STATEDIR}/${PN}"
+ touch "${D}${GAMES_STATEDIR}/${PN}/scores"
+ fperms 660 "${GAMES_STATEDIR}/${PN}/scores"
+ prepgamesdirs
+}