summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-05-31 19:11:08 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-05-31 19:11:08 +0000
commit9c41de522cfeb985be056492f98a434312912ae5 (patch)
tree7062e8e243d928e67d85788570a3a2c0101ab658 /games-arcade/project-starfighter
parentDropped amd64 keyword due to two missing deps bug#180397 - Thanks Paul Rauch ... (diff)
downloadgentoo-2-9c41de522cfeb985be056492f98a434312912ae5.tar.gz
gentoo-2-9c41de522cfeb985be056492f98a434312912ae5.tar.bz2
gentoo-2-9c41de522cfeb985be056492f98a434312912ae5.zip
Added menu entry. Bug #160243
(Portage version: 2.1.2.7)
Diffstat (limited to 'games-arcade/project-starfighter')
-rw-r--r--games-arcade/project-starfighter/ChangeLog8
-rw-r--r--games-arcade/project-starfighter/files/digest-project-starfighter-1.1-r13
-rw-r--r--games-arcade/project-starfighter/project-starfighter-1.1-r1.ebuild53
3 files changed, 63 insertions, 1 deletions
diff --git a/games-arcade/project-starfighter/ChangeLog b/games-arcade/project-starfighter/ChangeLog
index 5135376da0b1..2edbc0953ed0 100644
--- a/games-arcade/project-starfighter/ChangeLog
+++ b/games-arcade/project-starfighter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/project-starfighter
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/project-starfighter/ChangeLog,v 1.12 2007/04/24 15:04:41 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/project-starfighter/ChangeLog,v 1.13 2007/05/31 19:11:08 tupone Exp $
+
+*project-starfighter-1.1-r1 (31 May 2007)
+
+ 31 May 2007; Tupone Alfredo <tupone@gentoo.org>
+ +project-starfighter-1.1-r1.ebuild:
+ Added menu entry. Bug #160243 by Pacho Ramos
24 Apr 2007; Timothy Redaelli <drizzt@gentoo.org>
project-starfighter-1.1.ebuild:
diff --git a/games-arcade/project-starfighter/files/digest-project-starfighter-1.1-r1 b/games-arcade/project-starfighter/files/digest-project-starfighter-1.1-r1
new file mode 100644
index 000000000000..ffbddd0392d8
--- /dev/null
+++ b/games-arcade/project-starfighter/files/digest-project-starfighter-1.1-r1
@@ -0,0 +1,3 @@
+MD5 6a4b704dbc83c7403842b936f95ee958 project-starfighter-1.1.tar.gz 2523399
+RMD160 6cdc1e3fc4efaf56102f0e85f1ed479204a20202 project-starfighter-1.1.tar.gz 2523399
+SHA256 820d7c52fb997dca3e7b2a5f8183936474395dbae343f618540e0183a4c17186 project-starfighter-1.1.tar.gz 2523399
diff --git a/games-arcade/project-starfighter/project-starfighter-1.1-r1.ebuild b/games-arcade/project-starfighter/project-starfighter-1.1-r1.ebuild
new file mode 100644
index 000000000000..b25a0422ba2a
--- /dev/null
+++ b/games-arcade/project-starfighter/project-starfighter-1.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/project-starfighter/project-starfighter-1.1-r1.ebuild,v 1.1 2007/05/31 19:11:08 tupone Exp $
+
+inherit eutils games
+
+MY_P=${P/project-/}
+DESCRIPTION="A space themed shooter"
+HOMEPAGE="http://www.parallelrealities.co.uk/starfighter.php"
+# FIXME: Parallel Realities uses a lame download script.
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-image gif
+ then
+ die "You need to build media-libs/sdl-image with USE=gif!"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:-O3:${CXXFLAGS}:" makefile \
+ || die "sed makefile failed"
+ epatch "${FILESDIR}"/${PV}-ammo.patch
+}
+
+src_compile() {
+ emake DATA="${GAMES_DATADIR}/parallelrealities/" || die "emake failed"
+}
+
+src_install() {
+ dogamesbin starfighter || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/parallelrealities/"
+ doins starfighter.pak || die "doins failed"
+ dohtml -r docs/
+ newicon docs/rocketAmmo.png ${PN}.png
+ make_desktop_entry starfighter "Project: Starfighter" ${PN}.png
+ prepgamesdirs
+}