summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-16 16:16:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-16 16:16:04 +0000
commit62b65d4e11decf0495e48134903850ec7704dfa8 (patch)
treeb275795b9e85a47224037273ba222aab4cbd638c /games-arcade/njam
parentBump. (Manifest recommit) (diff)
downloadgentoo-2-62b65d4e11decf0495e48134903850ec7704dfa8.tar.gz
gentoo-2-62b65d4e11decf0495e48134903850ec7704dfa8.tar.bz2
gentoo-2-62b65d4e11decf0495e48134903850ec7704dfa8.zip
ppc support
Diffstat (limited to 'games-arcade/njam')
-rw-r--r--games-arcade/njam/njam-1.00.ebuild43
1 files changed, 21 insertions, 22 deletions
diff --git a/games-arcade/njam/njam-1.00.ebuild b/games-arcade/njam/njam-1.00.ebuild
index 8cbd6fdc6924..1b77d2abb9dc 100644
--- a/games-arcade/njam/njam-1.00.ebuild
+++ b/games-arcade/njam/njam-1.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/njam/njam-1.00.ebuild,v 1.3 2004/02/20 06:20:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/njam/njam-1.00.ebuild,v 1.4 2004/03/16 16:16:04 vapier Exp $
inherit eutils games
@@ -9,11 +9,10 @@ S="${WORKDIR}/${MY_P}"
DESCRIPTION="Multi or single-player network Pacman-like game in SDL"
HOMEPAGE="http://njam.sourceforge.net/"
SRC_URI="mirror://sourceforge/njam/${MY_P}.tar.gz"
-RESTRICT="nomirror"
-KEYWORDS="x86"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ppc"
RDEPEND=">=media-libs/sdl-mixer-1.2.5
>=media-libs/sdl-image-1.2.2
@@ -30,21 +29,21 @@ src_unpack() {
epatch ${FILESDIR}/${P}-conf.patch
sed -i \
- -e "s:\"data:\"${GAMES_DATADIR}/${PN}/data:" njam.cpp njamgame.cpp || \
- die "sed njam.cpp and njamgame.cpp failed"
+ -e "s:\"data:\"${GAMES_DATADIR}/${PN}/data:" njam.cpp njamgame.cpp \
+ || die "sed njam.cpp and njamgame.cpp failed"
sed -i \
-e "s:\"hiscore.dat:\"${GAMES_STATEDIR}/${PN}/hiscore.dat:" \
- -e "s:\"skins:\"${GAMES_DATADIR}/${PN}/skins:" njam.cpp || \
- die "sed njam.cpp failed"
+ -e "s:\"skins:\"${GAMES_DATADIR}/${PN}/skins:" njam.cpp \
+ || die "sed njam.cpp failed"
sed -i \
- -e "s:\"levels:\"${GAMES_DATADIR}/${PN}/levels:" njamedit.cpp || \
- die "sed njamedit.cpp failed"
+ -e "s:\"levels:\"${GAMES_DATADIR}/${PN}/levels:" njamedit.cpp \
+ || die "sed njamedit.cpp failed"
sed -i \
- -e "s:\"log.txt:\"/dev/null:" njamutils.cpp || \
- die "sed njamutils.cpp failed"
+ -e "s:\"log.txt:\"/dev/null:" njamutils.cpp \
+ || die "sed njamutils.cpp failed"
sed -i \
- -e "s:-O3:${CFLAGS}:" Makefile || \
- die "sed Makefile failed"
+ -e "s:-O3:${CFLAGS}:" Makefile \
+ || die "sed Makefile failed"
}
src_compile() {
@@ -52,17 +51,17 @@ src_compile() {
}
src_install() {
- dogamesbin njam || die "dogamesbin failed"
- dodoc CHANGES README TODO || die "dodoc failed"
- dohtml html/* || die "dohtml failed"
+ dogamesbin njam || die "dogamesbin failed"
+ dodoc CHANGES README TODO
+ dohtml html/*
insinto ${GAMES_DATADIR}/njam/data
- doins data/* || die "doins failed (data)"
+ doins data/* || die "doins failed (data)"
insinto ${GAMES_DATADIR}/njam/skins
- doins skins/* || die "doins failed (skins)"
+ doins skins/* || die "doins failed (skins)"
insinto ${GAMES_DATADIR}/njam/levels
- doins levels/* || die "doins failed (levels)"
- dodir "${GAMES_STATEDIR}/${PN}" || die "dodir failed"
- touch "${D}${GAMES_STATEDIR}/${PN}/hiscore.dat"
- fperms 664 "${GAMES_STATEDIR}/${PN}/hiscore.dat" || die "fperms failed"
+ doins levels/* || die "doins failed (levels)"
+ dodir ${GAMES_STATEDIR}/${PN}
+ touch ${D}/${GAMES_STATEDIR}/${PN}/hiscore.dat
+ fperms 664 ${GAMES_STATEDIR}/${PN}/hiscore.dat
prepgamesdirs
}