summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-01 06:01:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-01 06:01:49 +0000
commit408db9baa25cbba83fd307e6c709f88f6b664c80 (patch)
tree48f7a6f30e3c3da0b8bd55dccf4a6ac84f7b6c64 /games-arcade/bub-n-bros
parentEAPI=5 (diff)
downloadgentoo-2-408db9baa25cbba83fd307e6c709f88f6b664c80.tar.gz
gentoo-2-408db9baa25cbba83fd307e6c709f88f6b664c80.tar.bz2
gentoo-2-408db9baa25cbba83fd307e6c709f88f6b664c80.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade/bub-n-bros')
-rw-r--r--games-arcade/bub-n-bros/ChangeLog10
-rw-r--r--games-arcade/bub-n-bros/bub-n-bros-1.6.2.ebuild69
-rw-r--r--games-arcade/bub-n-bros/files/bub-n-bros-1.6.2-home.patch51
3 files changed, 128 insertions, 2 deletions
diff --git a/games-arcade/bub-n-bros/ChangeLog b/games-arcade/bub-n-bros/ChangeLog
index 6c1e577dbe01..e15e013c3982 100644
--- a/games-arcade/bub-n-bros/ChangeLog
+++ b/games-arcade/bub-n-bros/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/bub-n-bros
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/ChangeLog,v 1.20 2010/05/04 05:10:24 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/ChangeLog,v 1.21 2015/01/01 06:01:49 mr_bones_ Exp $
+
+*bub-n-bros-1.6.2 (01 Jan 2015)
+
+ 01 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> +bub-n-bros-1.6.2.ebuild,
+ +files/bub-n-bros-1.6.2-home.patch:
+ version bump
04 May 2010; Tupone Alfredo <tupone@gentoo.org> bub-n-bros-1.6.ebuild:
Force python2 fixing bug #312231 by arfrever@gentoo.org
diff --git a/games-arcade/bub-n-bros/bub-n-bros-1.6.2.ebuild b/games-arcade/bub-n-bros/bub-n-bros-1.6.2.ebuild
new file mode 100644
index 000000000000..32be8f380aa8
--- /dev/null
+++ b/games-arcade/bub-n-bros/bub-n-bros-1.6.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.6.2.ebuild,v 1.1 2015/01/01 06:01:49 mr_bones_ Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+MY_P=${P/-n-}
+DESCRIPTION="A multiplayer clone of the famous Bubble Bobble game"
+HOMEPAGE="http://bub-n-bros.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/pygame[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+ RDEPEND=${DEPEND}
+ REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ ecvs_clean
+ epatch "${FILESDIR}"/${P}-home.patch
+ python_fix_shebang .
+}
+
+src_compile() {
+ # Compile the "statesaver" extension module to enable the Clock bonus
+ cd "${S}"/bubbob
+ ${EPYTHON} setup.py build_ext -i || die
+
+ # Compile the extension module required for the X Window client
+ cd "${S}"/display
+ ${EPYTHON} setup.py build_ext -i || die
+
+ # Build images
+ cd "${S}"/bubbob/images
+ ${EPYTHON} buildcolors.py || die
+}
+
+src_install() {
+ local dir=$(games_get_libdir)/${PN}
+
+ exeinto "${dir}"
+ doexe *.py
+
+ insinto "${dir}"
+ doins -r bubbob common display java http2 metaserver
+
+ dodir "${GAMES_BINDIR}"
+ dosym "${dir}"/BubBob.py "${GAMES_BINDIR}"/bubnbros
+
+ python_optimize "${D}${dir}"
+
+ newicon http2/data/bob.png ${PN}.png
+ make_desktop_entry bubnbros Bub-n-Bros
+
+ prepgamesdirs
+}
diff --git a/games-arcade/bub-n-bros/files/bub-n-bros-1.6.2-home.patch b/games-arcade/bub-n-bros/files/bub-n-bros-1.6.2-home.patch
new file mode 100644
index 000000000000..4d2cc317aba3
--- /dev/null
+++ b/games-arcade/bub-n-bros/files/bub-n-bros-1.6.2-home.patch
@@ -0,0 +1,51 @@
+--- bubbob/images.py 2007-09-08 17:03:41.000000000 +0200
++++ bubbob/images.py 2007-09-08 17:57:45.000000000 +0200
+@@ -454,7 +454,6 @@
+ # check and maybe regenerate the colored image files
+ file = os.path.join('images', 'buildcolors.py')
+ g = {'__name__': '__auto__', '__file__': file}
+- execfile(file, g)
+ # replace the entries 'filename_%d.ppm' by a family of entries,
+ # one for each color
+ sprmap = {}
+--- display/pclient.py 2007-09-08 17:03:41.000000000 +0200
++++ display/pclient.py 2007-09-08 17:57:45.000000000 +0200
+@@ -162,8 +162,8 @@
+ if mode[-1].has_key('cfgfile'):
+ self.trackcfgfile = mode[-1]['cfgfile']
+ else:
+- self.trackcfgfile = os.path.join(DataChunk.SOURCEDIR,
+- 'http2', 'config.txt')
++ self.trackcfgfile = os.path.join(os.environ.get('HOME'),
++ '.bubnbros')
+ self.udpsock = None
+ self.udpsock_low = None
+ self.udpsock2 = None
+--- http2/httppages.py 2007-09-08 17:03:41.000000000 +0200
++++ http2/httppages.py 2007-09-08 17:57:45.000000000 +0200
+@@ -38,7 +38,7 @@
+
+
+ class PageServer:
+- CONFIGFILE = 'config.txt'
++ CONFIGFILE = '.bubnbros'
+ localservers = None
+
+ def __init__(self, Game):
+@@ -46,7 +46,7 @@
+ self.seed = hex(random.randrange(0x1000, 0x10000))
+ #self.unique_actions = {}
+ self.localhost = gamesrv.HOSTNAME
+- self.filename = os.path.join(LOCALDIR, self.CONFIGFILE)
++ self.filename = os.path.join(os.environ.get('HOME'), self.CONFIGFILE)
+ data = self.loadoptionfile()
+ self.globaloptions = Options(data.get('*', {}))
+ self.localoptions = Options(data.get(self.localhost, {}))
+@@ -333,7 +333,6 @@
+ 'buildcolors.py')
+ if os.path.exists(file):
+ g = {'__name__': '__auto__', '__file__': file}
+- execfile(file, g)
+
+ if port:
+ address = '%s:%s' % (host, port)