summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-05-11 05:16:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-05-11 05:16:44 +0000
commitb83144a5d9d082fb5efde29c53907c6721a8c6de (patch)
treed834bd97881fb6213b94963086213ff563a8bee6 /games-arcade/apricots
parentVersion bump (diff)
downloadgentoo-2-b83144a5d9d082fb5efde29c53907c6721a8c6de.tar.gz
gentoo-2-b83144a5d9d082fb5efde29c53907c6721a8c6de.tar.bz2
gentoo-2-b83144a5d9d082fb5efde29c53907c6721a8c6de.zip
EAPI=5; tidy
(Portage version: 2.1.11.62/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade/apricots')
-rw-r--r--games-arcade/apricots/ChangeLog8
-rw-r--r--games-arcade/apricots/apricots-0.2.6-r1.ebuild30
2 files changed, 19 insertions, 19 deletions
diff --git a/games-arcade/apricots/ChangeLog b/games-arcade/apricots/ChangeLog
index 6d1f9791428d..94796133116a 100644
--- a/games-arcade/apricots/ChangeLog
+++ b/games-arcade/apricots/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/apricots
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/ChangeLog,v 1.17 2011/06/01 15:05:41 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/ChangeLog,v 1.18 2013/05/11 05:16:44 mr_bones_ Exp $
+
+ 11 May 2013; Michael Sterrett <mr_bones_@gentoo.org> apricots-0.2.6-r1.ebuild:
+ EAPI=5; tidy
01 Jun 2011; Tupone Alfredo <tupone@gentoo.org> apricots-0.2.6-r1.ebuild:
Fix build with gcc-4.6 Bug #369121 by Diego Elio Pettenò
@@ -65,4 +68,3 @@
19 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+apricots-0.2.6.ebuild:
initial commit - ebuild submitted by Greg Watson via bug #64325
-
diff --git a/games-arcade/apricots/apricots-0.2.6-r1.ebuild b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
index c5da0a4cb69d..066d54f010a9 100644
--- a/games-arcade/apricots/apricots-0.2.6-r1.ebuild
+++ b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/apricots-0.2.6-r1.ebuild,v 1.11 2011/06/01 15:05:41 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/apricots-0.2.6-r1.ebuild,v 1.12 2013/05/11 05:16:44 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit autotools eutils games
DESCRIPTION="Fly a plane around bomb/shoot the enemy. Port of Planegame from Amiga."
@@ -14,9 +14,10 @@ SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND="media-libs/libsdl
+DEPEND="media-libs/libsdl[audio,video]
media-libs/openal
media-libs/freealut"
+RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-freealut.patch \
@@ -26,36 +27,33 @@ src_prepare() {
sed -i \
-e 's:-DAP_PATH=\\\\\\"$prefix.*":-DAP_PATH=\\\\\\"${GAMES_DATADIR}/${PN}/\\\\\\"":' \
- configure.in \
- || die "sed failed"
+ -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
+ configure.in || die
sed -i \
-e "s:filename(AP_PATH):filename(\"${GAMES_SYSCONFDIR}/${PN}/\"):" \
- ${PN}/init.cpp \
- || die "sed failed"
+ ${PN}/init.cpp || die
sed -i \
-e "s:apricots.cfg:${GAMES_SYSCONFDIR}/${PN}/apricots.cfg:" \
- README apricots.html \
- || die "sed failed"
+ README apricots.html || die
sed -i \
-e 's/-Wmissing-prototypes//' \
- acinclude.m4 \
- || die "sed failed"
+ acinclude.m4 || die
eautoreconf
}
src_compile() {
- emake LIBTOOL="/usr/bin/libtool" || die "emake failed"
+ emake LIBTOOL="/usr/bin/libtool"
}
src_install() {
dodoc AUTHORS README TODO ChangeLog
dohtml apricots.html
cd ${PN}
- dogamesbin apricots || die "dogamesbin failed"
+ dogamesbin apricots
insinto "${GAMES_DATADIR}"/${PN}
- doins *.wav *.psf *.shapes || die "doins failed"
+ doins *.wav *.psf *.shapes
insinto "${GAMES_SYSCONFDIR}"/${PN}
- doins apricots.cfg || die "doins apricots.cfg failed"
+ doins apricots.cfg
make_desktop_entry ${PN} Apricots
prepgamesdirs
}