summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-05-17 04:36:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-05-17 04:36:45 +0000
commite0de7f2a61c10a904ac2193ad856d224cef1819b (patch)
tree49a6677baad8e2e54351491470c5e86a767902da /games-action
parentVersion bump. (diff)
downloadgentoo-2-e0de7f2a61c10a904ac2193ad856d224cef1819b.tar.gz
gentoo-2-e0de7f2a61c10a904ac2193ad856d224cef1819b.tar.bz2
gentoo-2-e0de7f2a61c10a904ac2193ad856d224cef1819b.zip
version bump
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/abuse/ChangeLog8
-rw-r--r--games-action/abuse/abuse-0.8.ebuild47
-rw-r--r--games-action/abuse/files/abuse-0.8-gentoo.patch24
3 files changed, 78 insertions, 1 deletions
diff --git a/games-action/abuse/ChangeLog b/games-action/abuse/ChangeLog
index eeb182a66a7c..0edcb17cb76d 100644
--- a/games-action/abuse/ChangeLog
+++ b/games-action/abuse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/abuse
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/ChangeLog,v 1.11 2011/03/14 11:10:27 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/ChangeLog,v 1.12 2011/05/17 04:36:45 mr_bones_ Exp $
+
+*abuse-0.8 (17 May 2011)
+
+ 17 May 2011; Michael Sterrett <mr_bones_@gentoo.org> +abuse-0.8.ebuild,
+ +files/abuse-0.8-gentoo.patch:
+ version bump
14 Mar 2011; Alfredo Tupone <tupone@gentoo.org> abuse-0.7.1.ebuild,
metadata.xml:
diff --git a/games-action/abuse/abuse-0.8.ebuild b/games-action/abuse/abuse-0.8.ebuild
new file mode 100644
index 000000000000..7f249f04143c
--- /dev/null
+++ b/games-action/abuse/abuse-0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/abuse-0.8.ebuild,v 1.1 2011/05/17 04:36:45 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="port of Abuse by Crack Dot Com"
+HOMEPAGE="http://abuse.zoy.org/"
+SRC_URI="http://abuse.zoy.org/raw-attachment/wiki/download/${P}.tar.gz"
+
+LICENSE="GPL-2 WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.1.6[audio,opengl,video]
+ media-libs/sdl-mixer
+ virtual/opengl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-assetdir="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ # Source-based install
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ doicon doc/${PN}.png
+ make_desktop_entry abuse Abuse
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "NOTE: If you had previous version of abuse installed"
+ elog "you may need to remove ~/.abuse for the game to work correctly."
+}
diff --git a/games-action/abuse/files/abuse-0.8-gentoo.patch b/games-action/abuse/files/abuse-0.8-gentoo.patch
new file mode 100644
index 000000000000..c5d97834d9ec
--- /dev/null
+++ b/games-action/abuse/files/abuse-0.8-gentoo.patch
@@ -0,0 +1,24 @@
+diff -ru abuse-0.8.orig/Makefile.am abuse-0.8/Makefile.am
+--- abuse-0.8.orig/Makefile.am 2011-05-09 03:58:04.000000000 -0400
++++ abuse-0.8/Makefile.am 2011-05-16 22:22:51.642655295 -0400
+@@ -2,8 +2,6 @@
+
+ SUBDIRS = src data doc
+
+-EXTRA_DIST = COPYING.GPL COPYING.WTFPL PACKAGERS bootstrap
+-
+ dist-hook:
+ @echo ""
+ @echo " ===================================================="
+diff -ru abuse-0.8.orig/configure.ac abuse-0.8/configure.ac
+--- abuse-0.8.orig/configure.ac 2011-05-09 03:58:04.000000000 -0400
++++ abuse-0.8/configure.ac 2011-05-16 22:22:35.771824632 -0400
+@@ -90,8 +90,6 @@
+ fi
+ AM_CONDITIONAL(HAVE_NONFREE, test "${ac_cv_have_nonfree}" = "yes")
+
+-# Optimizations
+-CXXFLAGS="${CXXFLAGS} ${OPT} ${REL}"
+ # Code qui fait des warnings == code de porc == deux baffes dans ta gueule
+ CXXFLAGS="${CXXFLAGS} -Wall -Wpointer-arith -Wcast-align -Wcast-qual -Wsign-compare"
+