summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-31 02:49:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-31 02:49:11 +0000
commitcdf0a1cc21592ac117002bb3964c00d5253e8209 (patch)
treeeb78a9ba130f53134e1bcee238998b7f14deac81 /games-action
parentstable on arm64 (diff)
downloadgentoo-2-cdf0a1cc21592ac117002bb3964c00d5253e8209.tar.gz
gentoo-2-cdf0a1cc21592ac117002bb3964c00d5253e8209.tar.bz2
gentoo-2-cdf0a1cc21592ac117002bb3964c00d5253e8209.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/descent2-data/ChangeLog8
-rw-r--r--games-action/descent2-data/descent2-data-1.0.ebuild11
2 files changed, 11 insertions, 8 deletions
diff --git a/games-action/descent2-data/ChangeLog b/games-action/descent2-data/ChangeLog
index 324c80589cbb..914c9f16b4ca 100644
--- a/games-action/descent2-data/ChangeLog
+++ b/games-action/descent2-data/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/descent2-data
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/descent2-data/ChangeLog,v 1.8 2012/01/16 19:03:03 ulm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent2-data/ChangeLog,v 1.9 2015/03/31 02:49:11 mr_bones_ Exp $
+
+ 31 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> descent2-data-1.0.ebuild:
+ EAPI=5
16 Jan 2012; Ulrich Müller <ulm@gentoo.org> descent2-data-1.0.ebuild:
Migrate to cdrom.eclass, bug 398809.
@@ -34,4 +37,3 @@
+descent2-data-1.0.ebuild:
Initial import. Ebuild by Paul Bredbury <brebs@sent.com> based loosely on
the games-action/d2x ebuild. Closing bug #137307.
-
diff --git a/games-action/descent2-data/descent2-data-1.0.ebuild b/games-action/descent2-data/descent2-data-1.0.ebuild
index a2bbeb260d52..2e4f4add0175 100644
--- a/games-action/descent2-data/descent2-data-1.0.ebuild
+++ b/games-action/descent2-data/descent2-data-1.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/descent2-data/descent2-data-1.0.ebuild,v 1.9 2012/01/16 19:03:03 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent2-data/descent2-data-1.0.ebuild,v 1.10 2015/03/31 02:49:11 mr_bones_ Exp $
+EAPI=5
inherit eutils cdrom games
MY_PV=${PV/./}
@@ -61,7 +62,7 @@ src_unpack() {
[[ -e "${f}" ]] || f="${CDROM_ROOT}/d2data/${SOW}"
# Extract level data
- unarj e "${f}" || die "unarj ${f} failed"
+ unarj e "${f}" || die
if use videos ; then
# Include both high and low resolution movie files
@@ -69,7 +70,7 @@ src_unpack() {
f="${DISTDIR}/${m}"
[[ -e "${f}" ]] || f="${CDROM_ROOT}/d2data/${m}"
einfo "Copying ${m}"
- cp -f "${f}" . || die "cp ${f} failed"
+ cp -f "${f}" . || die
done
fi
@@ -83,7 +84,7 @@ src_unpack() {
src_install() {
insinto "${dir}"
- doins * || die "doins * failed"
+ doins *
dodoc doc/*