summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-28 14:10:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-28 14:10:22 +0000
commita2a0f5c4e71c8a590de45730cf7f4f05e9978aee (patch)
tree8b80c050c8e7223d6f6a28d1b70f2740e7cd9031 /games-action
parentcleanup (diff)
downloadgentoo-2-a2a0f5c4e71c8a590de45730cf7f4f05e9978aee.tar.gz
gentoo-2-a2a0f5c4e71c8a590de45730cf7f4f05e9978aee.tar.bz2
gentoo-2-a2a0f5c4e71c8a590de45730cf7f4f05e9978aee.zip
touchups/unmask
Diffstat (limited to 'games-action')
-rw-r--r--games-action/armagetron/armagetron-0.1.4.9.ebuild26
-rw-r--r--games-action/armagetron/armagetron-0.2.5.1.ebuild4
-rw-r--r--games-action/armagetron/armagetron-0.2.6.0.ebuild4
3 files changed, 19 insertions, 15 deletions
diff --git a/games-action/armagetron/armagetron-0.1.4.9.ebuild b/games-action/armagetron/armagetron-0.1.4.9.ebuild
index bb814b828a7b..bcbe311e03b3 100644
--- a/games-action/armagetron/armagetron-0.1.4.9.ebuild
+++ b/games-action/armagetron/armagetron-0.1.4.9.ebuild
@@ -1,41 +1,45 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.1.4.9.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.1.4.9.ebuild,v 1.2 2003/10/28 14:10:22 vapier Exp $
+
+inherit eutils flag-o-matic
-S=${WORKDIR}/${PN}
DESCRIPTION="armagetron: 3d tron lightcycles, just like the movie"
+HOMEPAGE="http://armagetron.sourceforge.net/"
SRC_URI="mirror://sourceforge/armagetron/armagetron_src_${PV}.tar.gz
http://armagetron.sourceforge.net/addons/moviesounds_fq.zip
http://armagetron.sourceforge.net/addons/moviepack.zip"
-HOMEPAGE="http://armagetron.sourceforge.net/"
-KEYWORDS="x86 ppc"
+
LICENSE="GPL-2"
SLOT="0"
-CXXFLAGS=${CXXFLAGS/-fno-exceptions/}
+KEYWORDS="x86 ppc"
+
RDEPEND="virtual/x11
virtual/opengl
media-libs/libsdl
media-libs/sdl-image
sys-libs/zlib
media-libs/libpng"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
-DEPEND="$RDEPEND app-arch/unzip"
+S=${WORKDIR}/${PN}
src_unpack() {
unpack armagetron_src_${PV}.tar.gz
unpack moviesounds_fq.zip
unpack moviepack.zip
- set > /tmp/emerge-env.txt
cd ${S}
# Doesn't find libs in /usr/X11R6/lib for some reason...patched
- patch < ${FILESDIR}/${P}-configure.patch || die "Patch 1 Failed"
+ epatch ${FILESDIR}/${P}-configure.patch
# Uses $SYNC which which conflicts with emerge
- patch < ${FILESDIR}/${P}-Makefile.global.in.patch || dir "Patch 2 Failed"
+ epatch ${FILESDIR}/${P}-Makefile.global.in.patch
}
src_compile() {
- CXXFLAGS="$CXXFLAGS" ./configure --prefix=/usr --host="${CHOST}" || die "config failed"
- make all || die "Make Failed"
+ filter-flags -fno-exceptions
+ econf || die "config failed"
+ emake all || die "Make Failed"
}
src_install () {
diff --git a/games-action/armagetron/armagetron-0.2.5.1.ebuild b/games-action/armagetron/armagetron-0.2.5.1.ebuild
index 6efc8168c868..fd43359828a5 100644
--- a/games-action/armagetron/armagetron-0.2.5.1.ebuild
+++ b/games-action/armagetron/armagetron-0.2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.2.5.1.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.2.5.1.ebuild,v 1.2 2003/10/28 14:10:22 vapier Exp $
inherit games
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/armagetron/${P}.tar.bz2
http://armagetron.sourceforge.net/addons/moviesounds_fq.zip
http://armagetron.sourceforge.net/addons/moviepack.zip"
HOMEPAGE="http://armagetron.sourceforge.net/"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ppc"
LICENSE="GPL-2"
SLOT="0"
CXXFLAGS=${CXXFLAGS/-fno-exceptions/}
diff --git a/games-action/armagetron/armagetron-0.2.6.0.ebuild b/games-action/armagetron/armagetron-0.2.6.0.ebuild
index e1eb2479cad4..69faf473a4b2 100644
--- a/games-action/armagetron/armagetron-0.2.6.0.ebuild
+++ b/games-action/armagetron/armagetron-0.2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.2.6.0.ebuild,v 1.2 2003/10/14 22:57:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.2.6.0.ebuild,v 1.3 2003/10/28 14:10:22 vapier Exp $
inherit games flag-o-matic
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/armagetron/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ppc"
RDEPEND="virtual/x11
virtual/opengl