summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-05-27 14:23:14 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-05-27 14:23:14 +0000
commit803fe11557f89e61e541183a15879620a4992295 (patch)
tree0b6a660d238d687b4119491c6ee3028b0baff56f /games-action
parentAdd a missing patch (bug #271350). (diff)
downloadgentoo-2-803fe11557f89e61e541183a15879620a4992295.tar.gz
gentoo-2-803fe11557f89e61e541183a15879620a4992295.tar.bz2
gentoo-2-803fe11557f89e61e541183a15879620a4992295.zip
Use cmake-utils eclass, bug #267776
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/openastromenace/ChangeLog6
-rw-r--r--games-action/openastromenace/openastromenace-1.2.0.ebuild18
2 files changed, 15 insertions, 9 deletions
diff --git a/games-action/openastromenace/ChangeLog b/games-action/openastromenace/ChangeLog
index 5348a7bc05f2..7d0165b174a3 100644
--- a/games-action/openastromenace/ChangeLog
+++ b/games-action/openastromenace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/openastromenace
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/openastromenace/ChangeLog,v 1.3 2009/03/20 07:05:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/openastromenace/ChangeLog,v 1.4 2009/05/27 14:23:14 nyhm Exp $
+
+ 27 May 2009; Tristan Heaven <nyhm@gentoo.org>
+ openastromenace-1.2.0.ebuild:
+ Use cmake-utils eclass, bug #267776
20 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org>
openastromenace-1.2.0.ebuild:
diff --git a/games-action/openastromenace/openastromenace-1.2.0.ebuild b/games-action/openastromenace/openastromenace-1.2.0.ebuild
index bc9050988f0f..3ecdfc9c5739 100644
--- a/games-action/openastromenace/openastromenace-1.2.0.ebuild
+++ b/games-action/openastromenace/openastromenace-1.2.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/openastromenace/openastromenace-1.2.0.ebuild,v 1.3 2009/03/20 07:05:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/openastromenace/openastromenace-1.2.0.ebuild,v 1.4 2009/05/27 14:23:14 nyhm Exp $
EAPI=2
-inherit eutils games
+inherit cmake-utils eutils games
DESCRIPTION="Modern 3D space shooter with spaceship upgrade possibilities"
HOMEPAGE="http://sourceforge.net/projects/openastromenace/"
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="linguas_de linguas_ru"
-RDEPEND="virtual/opengl
+DEPEND="virtual/opengl
virtual/glu
media-libs/libsdl[joystick]
media-libs/openal
@@ -27,8 +27,6 @@ RDEPEND="virtual/opengl
media-libs/libogg
media-libs/libvorbis
media-libs/jpeg"
-DEPEND="${RDEPEND}
- dev-util/cmake"
S=${WORKDIR}/OpenAstroMenaceSVN
@@ -36,13 +34,17 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-cmake.patch
}
+src_configure() {
+ local mycmakeargs="-DDATADIR=${GAMES_DATADIR}/${PN}"
+ cmake-utils_src_configure
+}
+
src_compile() {
- cmake -DDATADIR="${GAMES_DATADIR}"/${PN} . || die "cmake failed"
- emake || die "emake failed"
+ cmake-utils_src_compile
}
src_install() {
- newgamesbin AstroMenace ${PN} || die "newgamesbin failed"
+ newgamesbin "${CMAKE_BUILD_DIR}"/AstroMenace ${PN} || die "newgamesbin failed"
insinto "${GAMES_DATADIR}"/${PN}
doins -r ../DATA ../*.vfs || die "doins failed"
dosym gamelang_en.vfs "${GAMES_DATADIR}"/${PN}/gamelang.vfs