summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-08 04:55:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-08 04:55:26 +0000
commitfc89dbd4f4319acd919b7c78312e360f50640778 (patch)
treeb1dc860d740589e80af74da1e839cbd16d3d4270 /games-action/xshipwars
parentFixing up the initscript with a revbump; Minor cosmetic changes (diff)
downloadgentoo-2-fc89dbd4f4319acd919b7c78312e360f50640778.tar.gz
gentoo-2-fc89dbd4f4319acd919b7c78312e360f50640778.tar.bz2
gentoo-2-fc89dbd4f4319acd919b7c78312e360f50640778.zip
Version bump.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-action/xshipwars')
-rw-r--r--games-action/xshipwars/ChangeLog11
-rw-r--r--games-action/xshipwars/files/digest-xshipwars-2.4.74
-rw-r--r--games-action/xshipwars/files/xshipwars-2.4.7-64bit-warnings.patch94
-rw-r--r--games-action/xshipwars/files/xshipwars-2.4.7-build.patch101
-rw-r--r--games-action/xshipwars/xshipwars-2.4.7.ebuild91
5 files changed, 299 insertions, 2 deletions
diff --git a/games-action/xshipwars/ChangeLog b/games-action/xshipwars/ChangeLog
index 16cad55623fe..e54444e4ff2b 100644
--- a/games-action/xshipwars/ChangeLog
+++ b/games-action/xshipwars/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-action/xshipwars
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/ChangeLog,v 1.9 2005/08/07 12:49:31 hansmi Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/ChangeLog,v 1.10 2005/11/08 04:55:26 vapier Exp $
+
+*xshipwars-2.4.7 (08 Nov 2005)
+
+ 08 Nov 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/xshipwars-2.4.7-64bit-warnings.patch,
+ +files/xshipwars-2.4.7-build.patch, +xshipwars-2.4.7.ebuild:
+ Version bump.
07 Aug 2005; Michael Hanselmann <hansmi@gentoo.org>
xshipwars-1.34.0.ebuild:
diff --git a/games-action/xshipwars/files/digest-xshipwars-2.4.7 b/games-action/xshipwars/files/digest-xshipwars-2.4.7
new file mode 100644
index 000000000000..c5909ed53b49
--- /dev/null
+++ b/games-action/xshipwars/files/digest-xshipwars-2.4.7
@@ -0,0 +1,4 @@
+MD5 7492dbb34c98e89f60d130ad513d2947 stimages-1.9.5.tar.bz2 9258917
+MD5 c165c534b1550a6198f5b0188eabe8bc stsounds-1.5.2.tar.bz2 592445
+MD5 cf6ca61b99e5423b62ecc252fe443b1c xsw-2.4.7.tar.bz2 1096478
+MD5 40e66e37092383c4c44dd24f824ce278 xsw-data-2.4.7.tar.bz2 2639438
diff --git a/games-action/xshipwars/files/xshipwars-2.4.7-64bit-warnings.patch b/games-action/xshipwars/files/xshipwars-2.4.7-64bit-warnings.patch
new file mode 100644
index 000000000000..3f7cef364371
--- /dev/null
+++ b/games-action/xshipwars/files/xshipwars-2.4.7-64bit-warnings.patch
@@ -0,0 +1,94 @@
+--- client/images.cpp
++++ client/images.cpp
+@@ -285,8 +285,8 @@
+ {
+ fprintf(
+ stderr,
+-"ImgOpenData(): Warning: Unable to open TGA image data: 0x%.8x\n",
+- (u_int32_t)data
++"ImgOpenData(): Warning: Unable to open TGA image data: %p\n",
++ data
+ );
+ ImgUnload(img_num);
+ return(-1);
+--- global/osw-x.cpp
++++ global/osw-x.cpp
+@@ -8598,8 +8598,8 @@
+ /* Display */
+ fprintf(
+ stderr,
+-" X server display connection pointer: 0x%.8x\n",
+- (u_int32_t)error_event->display
++" X server display connection pointer: %p\n",
++ error_event->display
+ );
+
+ /* Serial number */
+--- widgets/wfile.cpp
++++ widgets/wfile.cpp
+@@ -213,7 +213,7 @@
+ status = TgaReadFromData(data, td, gui->depth);
+ if(status != TgaSuccess)
+ {
+- fprintf(stderr, "WidgetLoadImageFromTgaData(): 0x%.8x: ", (u_int32_t)data);
++ fprintf(stderr, "WidgetLoadImageFromTgaData(): %p: ", data);
+ switch(status)
+ {
+ case TgaNoBuffers:
+@@ -248,8 +248,8 @@
+ {
+ fprintf(
+ stderr,
+-"0x%.8x: Error: Unable to allocate GUI image.\n",
+- (u_int32_t)data
++"%p: Error: Unable to allocate GUI image.\n",
++ data
+ );
+ }
+ else
+@@ -517,8 +517,8 @@
+ {
+ fprintf(
+ stderr,
+-"0x%.8x: Unable to open XPM data.\n",
+- (u_int32_t)data
++"%p: Unable to open XPM data.\n",
++ data
+ );
+ return(None);
+ }
+--- widgets/wglobal.cpp
++++ widgets/wglobal.cpp
+@@ -602,8 +602,8 @@
+
+ sprintf(
+ s,
+-"WidgetDestroyGlobals(): Warning: %s widget #%i 0x%.8x was not destroyed.",
+- type_name, i, (u_int32_t)widget
++"WidgetDestroyGlobals(): Warning: %s widget #%i %p was not destroyed.",
++ type_name, i, widget
+ );
+ fprintf(stderr, "%s\n", s);
+ free(s);
+@@ -1484,8 +1484,8 @@
+ default:
+ fprintf(
+ stderr,
+-"WidgetDestroy(): Widget 0x%.8x: Unsupported widget type (type=%i).\n",
+- (u_int32_t)widget,
++"WidgetDestroy(): Widget %p: Unsupported widget type (type=%i).\n",
++ widget,
+ type
+ );
+ break;
+--- widgets/wlist.cpp
++++ widgets/wlist.cpp
+@@ -2584,7 +2584,7 @@
+
+ return(w);
+ #else
+- return(NULL);
++ return(None);
+ #endif
+ }
+
diff --git a/games-action/xshipwars/files/xshipwars-2.4.7-build.patch b/games-action/xshipwars/files/xshipwars-2.4.7-build.patch
new file mode 100644
index 000000000000..82823effec15
--- /dev/null
+++ b/games-action/xshipwars/files/xshipwars-2.4.7-build.patch
@@ -0,0 +1,101 @@
+--- client/platforms.ini
++++ client/platforms.ini
+@@ -199,7 +199,7 @@
+ PlatformFeature = X11
+ Description = X Window Systems
+ MustExist = Yes
+- FeatureCFLAGS = -DUSE_XSHM -DHAVE_MWMUTIL_H
++ FeatureCFLAGS = -DUSE_XSHM -DHAVE_MWMUTIL_H -DHAVE_X
+ FeatureLIBS = -lX11 -lXext
+ FeatureLIB_DIR = -L/usr/X11R6/lib/
+ FeatureDepend = X11-lib
+--- unvedit/platforms.ini
++++ unvedit/platforms.ini
+@@ -140,7 +140,7 @@
+ PlatformFeature = X11
+ Description = X Window Systems
+ MustExist = Yes
+- FeatureCFLAGS = -DUSE_XSHM -DHAVE_MWMUTIL_H
++ FeatureCFLAGS = -DUSE_XSHM -DHAVE_MWMUTIL_H -DHAVE_X
+ FeatureLIBS = -lX11 -lXext
+ FeatureLIB_DIR = -L/usr/X11R6/lib/
+ FeatureDepend = X11-lib
+--- monitor/platforms.ini
++++ monitor/platforms.ini
+@@ -140,7 +140,7 @@
+ PlatformFeature = X11
+ Description = X Window Systems
+ MustExist = Yes
+- FeatureCFLAGS = -DUSE_XSHM -DHAVE_MWMUTIL_H
++ FeatureCFLAGS = -DUSE_XSHM -DHAVE_MWMUTIL_H -DHAVE_X
+ FeatureLIBS = -lX11 -lXext
+ FeatureLIB_DIR = -L/usr/X11R6/lib/
+ FeatureDepend = X11-lib
+--- client/Makefile.install.UNIX
++++ client/Makefile.install.UNIX
+@@ -11,9 +11,9 @@
+ #
+
+ INSTALL = install
+-INSTBINFLAGS = -m 0755 -s
++INSTBINFLAGS = -m 0755
+ INSTUIDFLAGS = -m 4755
+-INSTLIBFLAGS = -m 0755 -s
++INSTLIBFLAGS = -m 0755
+ INSTINCFLAGS = -m 0644
+ INSTMANFLAGS = -m 0644
+ INSTCFGFLAGS = -m 0644
+@@ -26,8 +26,10 @@
+ MKDIRFLAGS = -p
+
+
+-GAMES_DIR = $(PREFIX)/games
+-XSW_DIR = $(PREFIX)/share/games/xshipwars
++BINDIR = $(PREFIX)/games
++GAMES_DIR = $(DESTDIR)$(BINDIR)
++DATADIR = $(PREFIX)/share/games
++XSW_DIR = $(DESTDIR)$(DATADIR)/xshipwars
+ XSW_ETC_DIR = $(XSW_DIR)/etc
+
+ XSW_CFG_FILE = xsw.ini
+--- monitor/Makefile.install.UNIX
++++ monitor/Makefile.install.UNIX
+@@ -27,8 +27,10 @@
+ MKDIR = mkdir
+ MKDIRFLAGS = -p
+
+-GAMES_DIR = $(PREFIX)/games
+-XSW_DIR = $(PREFIX)/share/games/xshipwars
++BINDIR = $(PREFIX)/games
++GAMES_DIR = $(DESTDIR)$(BINDIR)
++DATADIR = $(PREFIX)/share/games
++XSW_DIR = $(DESTDIR)$(DATADIR)/xshipwars
+ MONITOR_IMAGES_DIR = $(XSW_DIR)/images/monitor
+
+ HR = "-------------------------------------------------------------------------"
+--- server/Makefile.install.UNIX
++++ server/Makefile.install.UNIX
+@@ -29,7 +29,7 @@
+ MKDIRFLAGS = -p
+
+
+-SWSERV_BASE_DIR = $(PREFIX)/swserv
++SWSERV_BASE_DIR = $(DESTDIR)$(PREFIX)/swserv
+
+ SWSERV_BIN_DIR = $(SWSERV_BASE_DIR)/bin
+ SWSERV_DB_DIR = $(SWSERV_BASE_DIR)/db
+--- unvedit/Makefile.install.UNIX
++++ unvedit/Makefile.install.UNIX
+@@ -26,8 +26,10 @@
+ MKDIR = mkdir
+ MKDIRFLAGS = -p
+
+-GAMES_BIN_DIR = $(PREFIX)/games
+-XSW_DATA_DIR = $(PREFIX)/share/games/xshipwars
++BINDIR = $(PREFIX)/games
++GAMES_BIN_DIR = $(DESTDIR)$(BINDIR)
++DATADIR = $(PREFIX)/share/games
++XSW_DATA_DIR = $(DESTDIR)$(DATADIR)/xshipwars
+ UNVEDIT_IMAGES_DIR = $(XSW_DATA_DIR)/images/unvedit
+
+ HR = "-------------------------------------------------------------------------"
diff --git a/games-action/xshipwars/xshipwars-2.4.7.ebuild b/games-action/xshipwars/xshipwars-2.4.7.ebuild
new file mode 100644
index 000000000000..784b2a163b1d
--- /dev/null
+++ b/games-action/xshipwars/xshipwars-2.4.7.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-2.4.7.ebuild,v 1.1 2005/11/08 04:55:26 vapier Exp $
+
+inherit toolchain-funcs eutils games
+
+MY_P=xsw-${PV}
+DESCRIPTION="massively multi-player, ultra graphical, space-oriented gaming system designed exclusively for network play"
+HOMEPAGE="http://wolfpack.twu.net/ShipWars/XShipWars/"
+SRC_URI="http://wolfpack.twu.net/users/wolfpack/${MY_P}.tar.bz2
+ http://wolfpack.twu.net/users/wolfpack/xsw-data-${PV}.tar.bz2
+ http://wolfpack.twu.net/users/wolfpack/stimages-1.9.5.tar.bz2
+ http://wolfpack.twu.net/users/wolfpack/stsounds-1.5.2.tar.bz2"
+
+LICENSE="GPL-2 xshipwars"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="joystick yiff esound"
+
+DEPEND="virtual/x11
+ joystick? ( media-libs/libjsw )
+ yiff? ( media-libs/yiff )
+ esound? ( >=media-sound/esound-0.2.23 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-64bit-warnings.patch
+ epatch "${FILESDIR}"/${P}-build.patch
+# epatch "${FILESDIR}"/${P}-missing-strlen-def.patch
+ sed -i \
+ -e "/^BINDIR/s:=.*:=${GAMES_BINDIR}:" \
+ -e "/^DATADIR/s:=.*:=${GAMES_DATADIR}:" \
+ */Makefile.install.UNIX || die
+}
+
+src_compile() {
+ local myconf=" \
+ --disable-debug \
+ --disable-arch-i486 \
+ --disable-arch-i586 \
+ --disable-arch-i686 \
+ --disable-arch-pentiumpro \
+ $(use_enable joystick libjsw) \
+ --enable-X11 \
+ --enable-libXpm \
+ $(use_enable yiff Y2) \
+ $(use_enable esound ESounD) \
+ "
+ # xsw uses --{en,dis}able=FEATURE syntax
+ myconf=${myconf//able-/able=}
+
+ local x
+ for x in client monitor unvedit ; do #server
+ echo ./configure.${x} Linux --prefix=${GAMES_PREFIX} ${myconf}
+ ./configure.${x} Linux --prefix=${GAMES_PREFIX} ${myconf} || die "configure ${x}"
+ emake -j1 -f Makefile.${x} all || die "build ${x}"
+ done
+}
+
+src_install() {
+ local x
+ for x in client monitor unvedit ; do #server
+ make -f Makefile.${x} DESTDIR="${D}" install || die "install ${x}"
+ done
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${WORKDIR}"/{etc,images,sounds} || die "doins data"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "Before playing, you should get a copy of the installed "
+ einfo "global XShipWars client configuration file and copy it to "
+ einfo "your home directory: "
+ echo
+ einfo "# mkdir ~/.shipwars/"
+ einfo "# cd /usr/share/games/xshipwars/etc/ "
+ einfo "# cp xshipwarsrc ~/.shipwars/xshipwarsrc "
+ einfo "# cp universes ~/.shipwars/universes "
+ echo
+ einfo "You will probably need to edit the xshipwarsrc to fit your needs."
+ echo
+ einfo "Then type 'xsw &' to start the game"
+ echo
+}