summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-12-02 21:46:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-12-02 21:46:10 +0000
commit369c64ab0dc422831da002c17c48c8870d5cf573 (patch)
treebaa1f3f932caff4b9e031eb184ef6ef65a461c52 /games-action/wordwarvi
parentNo need for flag-o-matic anymore. (diff)
downloadgentoo-2-369c64ab0dc422831da002c17c48c8870d5cf573.tar.gz
gentoo-2-369c64ab0dc422831da002c17c48c8870d5cf573.tar.bz2
gentoo-2-369c64ab0dc422831da002c17c48c8870d5cf573.zip
version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'games-action/wordwarvi')
-rw-r--r--games-action/wordwarvi/ChangeLog8
-rw-r--r--games-action/wordwarvi/wordwarvi-0.23.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/games-action/wordwarvi/ChangeLog b/games-action/wordwarvi/ChangeLog
index 1736dfaaffd7..c51e919792c0 100644
--- a/games-action/wordwarvi/ChangeLog
+++ b/games-action/wordwarvi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/wordwarvi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.1 2008/08/04 03:28:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.2 2008/12/02 21:46:10 mr_bones_ Exp $
+
+*wordwarvi-0.23 (02 Dec 2008)
+
+ 02 Dec 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +wordwarvi-0.23.ebuild:
+ version bump
*wordwarvi-0.22 (04 Aug 2008)
diff --git a/games-action/wordwarvi/wordwarvi-0.23.ebuild b/games-action/wordwarvi/wordwarvi-0.23.ebuild
new file mode 100644
index 000000000000..321240f3423d
--- /dev/null
+++ b/games-action/wordwarvi/wordwarvi-0.23.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/wordwarvi-0.23.ebuild,v 1.1 2008/12/02 21:46:10 mr_bones_ Exp $
+
+EAPI=1
+inherit eutils games
+
+DESCRIPTION="A retro side-scrolling shoot'em up based on the editor war story"
+HOMEPAGE="http://wordwarvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/wordwarvi/${P}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Attribution-2.0 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vorbis"
+
+RDEPEND="x11-libs/gtk+:2
+ vorbis? ( media-libs/libvorbis
+ >=media-libs/portaudio-0.19 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^DATADIR/s/=/?=/' \
+ -e '/^OPTIMIZE_FLAG/s/=.*/=$(CFLAGS)/' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ WITHAUDIO=$(use vorbis && echo yes || echo no) all \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ WITHAUDIO=$(use vorbis && echo yes || echo no) all \
+ install || die "emake install failed"
+ use vorbis || rm -rf "${D}${GAMES_DATADIR}/${PN}"
+ dodoc README AUTHORS changelog.txt AAA_HOW_TO_MAKE_NEW_LEVELS.txt
+ newicon icons/wordwarvi_icon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Word War vi"
+ prepgamesdirs
+}