summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-26 18:55:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-26 18:55:28 +0000
commit2965c659067b00240ec7a20ee46776a56a73913c (patch)
tree87fe6172e9495a4fb3f60a1cb9304684bbd02b60 /games-action/violetland
parentstable amd64, bug 316319 (diff)
downloadgentoo-2-2965c659067b00240ec7a20ee46776a56a73913c.tar.gz
gentoo-2-2965c659067b00240ec7a20ee46776a56a73913c.tar.bz2
gentoo-2-2965c659067b00240ec7a20ee46776a56a73913c.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action/violetland')
-rw-r--r--games-action/violetland/ChangeLog8
-rw-r--r--games-action/violetland/violetland-0.3.0.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
index 1444302790ec..0466679c852e 100644
--- a/games-action/violetland/ChangeLog
+++ b/games-action/violetland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/violetland
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.9 2010/05/26 18:24:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.10 2010/05/26 18:55:28 mr_bones_ Exp $
+
+*violetland-0.3.0 (26 May 2010)
+
+ 26 May 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +violetland-0.3.0.ebuild:
+ version bump
26 May 2010; Pacho Ramos <pacho@gentoo.org> violetland-0.2.9.ebuild:
stable amd64, bug 315495
diff --git a/games-action/violetland/violetland-0.3.0.ebuild b/games-action/violetland/violetland-0.3.0.ebuild
new file mode 100644
index 000000000000..a53328980ff9
--- /dev/null
+++ b/games-action/violetland/violetland-0.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.3.0.ebuild,v 1.1 2010/05/26 18:55:28 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils cmake-utils games
+
+DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
+HOMEPAGE="http://code.google.com/p/violetland/"
+SRC_URI="http://violetland.googlecode.com/files/${PN}-v${PV}-src.zip"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[audio,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ x11-libs/libXext
+ x11-libs/libSM
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_prepare() {
+ sed -i \
+ -e "/README_EN.TXT/d" \
+ -e "/README_RU.TXT/d" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DDATA_INSTALL_DIR=${GAMES_DATADIR}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README_EN.TXT CHANGELOG" cmake-utils_src_install
+ newicon icon-light.png ${PN}.png
+ make_desktop_entry ${PN} VioletLand
+ prepgamesdirs
+}