summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-05-19 06:02:58 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-05-19 06:02:58 +0000
commitbd67d67a4f0b11556738a6665a04c675ea968d5e (patch)
treefa0a6722c7148badf15d00e648a8f4bb62d93de5 /games-action/powermanga
parentDrop jruby support since we don't have a jruby-ready rspec:2 in the tree yet. (diff)
downloadgentoo-2-bd67d67a4f0b11556738a6665a04c675ea968d5e.tar.gz
gentoo-2-bd67d67a4f0b11556738a6665a04c675ea968d5e.tar.bz2
gentoo-2-bd67d67a4f0b11556738a6665a04c675ea968d5e.zip
Fix underlinking. Bug #367431
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'games-action/powermanga')
-rw-r--r--games-action/powermanga/ChangeLog8
-rw-r--r--games-action/powermanga/files/powermanga-0.90-underlink.patch28
-rw-r--r--games-action/powermanga/powermanga-0.90.ebuild8
3 files changed, 39 insertions, 5 deletions
diff --git a/games-action/powermanga/ChangeLog b/games-action/powermanga/ChangeLog
index 6c5bcff70bc3..722c0ff154ba 100644
--- a/games-action/powermanga/ChangeLog
+++ b/games-action/powermanga/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/powermanga
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.19 2010/11/13 07:39:56 mr_bones_ Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.20 2011/05/19 06:02:58 tupone Exp $
+
+ 19 May 2011; Tupone Alfredo <tupone@gentoo.org> powermanga-0.90.ebuild,
+ +files/powermanga-0.90-underlink.patch:
+ Fix underlinking. Bug #367431 by Diego Elio Pettenò
13 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org>
powermanga-0.90.ebuild:
diff --git a/games-action/powermanga/files/powermanga-0.90-underlink.patch b/games-action/powermanga/files/powermanga-0.90-underlink.patch
new file mode 100644
index 000000000000..8afd5ef8ef6f
--- /dev/null
+++ b/games-action/powermanga/files/powermanga-0.90-underlink.patch
@@ -0,0 +1,28 @@
+--- configure.ac.old 2011-05-19 07:52:47.862129502 +0200
++++ configure.ac 2011-05-19 07:52:59.780877256 +0200
+@@ -31,14 +31,11 @@
+
+
+ dnl Check for SDL_mixer
+-LDFLAGS_save="${LDFLAGS} ${SDL_LIBS}"
+-LDFLAGS="${LDFLAGS} ${SDL_LIBS}"
+ AC_CHECK_LIB(SDL_mixer, Mix_GetChunk, [
+ SDL_LIBS="-lSDL_mixer ${SDL_LIBS}"
+ ],[
+ AC_MSG_ERROR(Could not find -lSDL_mixer)
+ ])
+-LDFLAGS_="${LDFLAGS_save}"
+
+ dnl ttf and sdl_image for shareware version only
+ dnl AC_CHECK_LIB(SDL_ttf,TTF_Init,,[AC_MSG_ERROR([SDL_ttf])])
+--- src/Makefile.am.old 2011-05-19 07:58:50.128783975 +0200
++++ src/Makefile.am 2011-05-19 07:58:55.639128359 +0200
+@@ -7,7 +7,7 @@
+ powermanga_SOURCES = $(SOURCES_MAIN) $(SOURCES_EXTRA)
+ #powermanga_CXXFLAGS = -DPREFIX=\"$(prefix)\" -DSCOREFILE=\"$(scoredir)/$(score)\" @XLIB_CFLAGS@ @SDL_CFLAGS@
+ powermanga_CFLAGS = -DPREFIX=\"$(prefix)\" -DSCOREFILE=\"$(scoredir)/$(score)\" @XLIB_CFLAGS@ @SDL_CFLAGS@
+-powermanga_LDADD = @XLIB_LIBS@ @SDL_LIBS@
++powermanga_LDADD = @XLIB_LIBS@ @SDL_LIBS@ -lm
+
+ install-data-hook:
+ -chown root:games "$(DESTDIR)/$(gamesdir)/powermanga"
diff --git a/games-action/powermanga/powermanga-0.90.ebuild b/games-action/powermanga/powermanga-0.90.ebuild
index 87ba745e050c..ba90e33553f8 100644
--- a/games-action/powermanga/powermanga-0.90.ebuild
+++ b/games-action/powermanga/powermanga-0.90.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.90.ebuild,v 1.8 2010/11/13 07:39:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.90.ebuild,v 1.9 2011/05/19 06:02:58 tupone Exp $
EAPI=2
-inherit eutils games
+inherit eutils autotools games
DESCRIPTION="An arcade 2D shoot-em-up game"
HOMEPAGE="http://linux.tlk.fr/"
@@ -32,6 +32,8 @@ src_prepare() {
#endif
EOF
done
+ epatch "${FILESDIR}"/${P}-underlink.patch
+ eautoreconf
}
src_configure() {