summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-06-06 04:12:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-06-06 04:12:20 +0000
commit55e406bf9abfa6475c561a22ff2d8fddf75cd529 (patch)
tree53fd6ce9db848afa7b899f1a0b7a48e08692040d /games-action/d2x-rebirth
parentVersion bump thanks to Marcin Mirosław (bug #369957). (diff)
downloadgentoo-2-55e406bf9abfa6475c561a22ff2d8fddf75cd529.tar.gz
gentoo-2-55e406bf9abfa6475c561a22ff2d8fddf75cd529.tar.bz2
gentoo-2-55e406bf9abfa6475c561a22ff2d8fddf75cd529.zip
EAPI=2; add use deps for physfs (bug #370187)
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-action/d2x-rebirth')
-rw-r--r--games-action/d2x-rebirth/ChangeLog7
-rw-r--r--games-action/d2x-rebirth/d2x-rebirth-0.50.ebuild22
2 files changed, 15 insertions, 14 deletions
diff --git a/games-action/d2x-rebirth/ChangeLog b/games-action/d2x-rebirth/ChangeLog
index dc17de61b143..6101f0d1898a 100644
--- a/games-action/d2x-rebirth/ChangeLog
+++ b/games-action/d2x-rebirth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/d2x-rebirth
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x-rebirth/ChangeLog,v 1.2 2008/03/06 03:15:20 wolf31o2 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x-rebirth/ChangeLog,v 1.3 2011/06/06 04:12:20 mr_bones_ Exp $
+
+ 06 Jun 2011; Michael Sterrett <mr_bones_@gentoo.org> d2x-rebirth-0.50.ebuild:
+ EAPI=2; add use deps for physfs (bug #370187)
06 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org>
d2x-rebirth-0.50.ebuild:
diff --git a/games-action/d2x-rebirth/d2x-rebirth-0.50.ebuild b/games-action/d2x-rebirth/d2x-rebirth-0.50.ebuild
index 6780d9b3c0b1..86d1b6c764e9 100644
--- a/games-action/d2x-rebirth/d2x-rebirth-0.50.ebuild
+++ b/games-action/d2x-rebirth/d2x-rebirth-0.50.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x-rebirth/d2x-rebirth-0.50.ebuild,v 1.3 2008/03/06 03:15:20 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x-rebirth/d2x-rebirth-0.50.ebuild,v 1.4 2011/06/06 04:12:20 mr_bones_ Exp $
+EAPI=2
inherit autotools eutils games
# DV is the Descent version. Used because the d1x-rebirth ebuild is similar.
@@ -35,7 +36,7 @@ UIRDEPEND="media-libs/alsa-lib
media-libs/libpng
>=media-libs/libsdl-1.2.9
>=media-libs/sdl-image-1.2.3-r1
- >=dev-games/physfs-1.0.1
+ >=dev-games/physfs-1.0.1[hog,zip]
virtual/glu
virtual/opengl
x11-libs/libX11
@@ -53,10 +54,7 @@ DEPEND="${UIRDEPEND}
S=${WORKDIR}/${PN}
dir=${GAMES_DATADIR}/${DVX}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Midi music - awe32 for most SoundBlaster cards
if use awe32 ; then
sed -i \
@@ -70,8 +68,7 @@ src_unpack() {
eautoreconf || die "eautoreconf failed"
}
-src_compile() {
-
+src_configure() {
# Configure options are specified in dxx-compile.txt
local opts
use x86 || opts="${opts} --disable-fastfileio"
@@ -84,10 +81,11 @@ src_compile() {
egamesconf \
${opts} \
--with-sharepath="${dir}" \
- --with-opengl \
- || die "egamesconf failed"
+ --with-opengl
+}
- emake -j1 || die "emake failed"
+src_compile() {
+ emake -j1 || die
}
src_install() {