summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-03 07:03:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-03 07:03:55 +0000
commit884c225a975aa7580c9499ea3c2e55baa0c3f3e3 (patch)
tree962ef854813bd6749c0f7d3f3db5f46e559ea9ec /games-action/0verkill
parentMoved from net-mail/bogofilter to mail-filter/bogofilter (diff)
downloadgentoo-2-884c225a975aa7580c9499ea3c2e55baa0c3f3e3.tar.gz
gentoo-2-884c225a975aa7580c9499ea3c2e55baa0c3f3e3.tar.bz2
gentoo-2-884c225a975aa7580c9499ea3c2e55baa0c3f3e3.zip
error check sed; fix use invocation
Diffstat (limited to 'games-action/0verkill')
-rw-r--r--games-action/0verkill/0verkill-0.16-r2.ebuild12
-rw-r--r--games-action/0verkill/ChangeLog6
2 files changed, 12 insertions, 6 deletions
diff --git a/games-action/0verkill/0verkill-0.16-r2.ebuild b/games-action/0verkill/0verkill-0.16-r2.ebuild
index 94ce31896ed7..936bd52faca2 100644
--- a/games-action/0verkill/0verkill-0.16-r2.ebuild
+++ b/games-action/0verkill/0verkill-0.16-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/0verkill-0.16-r2.ebuild,v 1.4 2004/03/31 03:30:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/0verkill-0.16-r2.ebuild,v 1.5 2004/06/03 07:03:55 mr_bones_ Exp $
inherit eutils games
@@ -23,19 +23,21 @@ src_unpack() {
epatch ${FILESDIR}/${PV}-docs.patch
epatch ${FILESDIR}/${PV}-home-overflow.patch
epatch ${FILESDIR}/${PV}-gentoo-paths.patch
- sed -i "s:data/:${GAMES_DATADIR}/${PN}/data/:" cfg.h
+ sed -i \
+ -e "s:data/:${GAMES_DATADIR}/${PN}/data/:" cfg.h \
+ || die "sed failed"
}
src_compile() {
- egamesconf `use_with X x` || die
- emake || die
+ egamesconf $(use_with X x) || die
+ emake || die "emake failed"
}
src_install() {
dogamesbin 0verkill
newgamesbin avi 0verkill-avi
newgamesbin editor 0verkill-editor
- if [ `use X` ] ; then
+ if use X ; then
dogamesbin x0verkill
newgamesbin xavi x0verkill-avi
newgamesbin xeditor x0verkill-editor
diff --git a/games-action/0verkill/ChangeLog b/games-action/0verkill/ChangeLog
index 39962236d4cd..8e6d7bc72bb2 100644
--- a/games-action/0verkill/ChangeLog
+++ b/games-action/0verkill/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/0verkill
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/ChangeLog,v 1.7 2004/03/31 03:30:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/ChangeLog,v 1.8 2004/06/03 07:03:55 mr_bones_ Exp $
+
+ 03 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ 0verkill-0.16-r2.ebuild:
+ error check sed; fix use invocation
30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
0verkill-0.16-r2.ebuild: