summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-03-19 06:13:41 +0000
committerMichał Górny <mgorny@gentoo.org>2013-03-19 06:13:41 +0000
commitbdf70c2f181ef6b6ac26cbe50020082207c140fb (patch)
tree02bde015c8db68a41b6bbb51d0f60a110308f073 /eclass/distutils-r1.eclass
parentInstall the python gdb module in the right place #443510 by Jan Pobrislo. (diff)
downloadgentoo-2-bdf70c2f181ef6b6ac26cbe50020082207c140fb.tar.gz
gentoo-2-bdf70c2f181ef6b6ac26cbe50020082207c140fb.tar.bz2
gentoo-2-bdf70c2f181ef6b6ac26cbe50020082207c140fb.zip
Pass --build-platlib and --build-purelib separately to distutils. This allows to change them to different locations if necessary (bug #455332).
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass15
1 files changed, 12 insertions, 3 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 5c628edea49e..0982e6cb4c5b 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.64 2013/03/13 21:51:05 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.65 2013/03/19 06:13:41 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -234,8 +234,17 @@ esetup.py() {
add_args+=(
build
--build-base "${BUILD_DIR}"
- # using a single directory for them helps us export ${PYTHONPATH}
- --build-lib "${BUILD_DIR}/lib"
+
+ # using a single directory for them helps us export
+ # ${PYTHONPATH} and ebuilds find the sources independently
+ # of whether the package installs extensions or not
+ #
+ # note: due to some packages (wxpython) relying on separate
+ # platlib & purelib dirs, we do not set --build-lib (which
+ # can not be overriden with --build-*lib)
+ --build-platlib "${BUILD_DIR}/lib"
+ --build-purelib "${BUILD_DIR}/lib"
+
# make the ebuild writer lives easier
--build-scripts "${BUILD_DIR}/scripts"
)