summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-04 12:18:43 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-04 12:18:43 +0000
commitd4dd7cab8daeca9940be0e93a6437e9271354991 (patch)
tree10a6ba02b6f9976f063f16af34cb1ed0ba0fc42a /eclass/commonbox.eclass
parentSecurity update. (diff)
downloadgentoo-2-d4dd7cab8daeca9940be0e93a6437e9271354991.tar.gz
gentoo-2-d4dd7cab8daeca9940be0e93a6437e9271354991.tar.bz2
gentoo-2-d4dd7cab8daeca9940be0e93a6437e9271354991.zip
new commonbox class to correct openbox errors, version bump on fluxbox, and version bumpo on commonbox-styles
Diffstat (limited to 'eclass/commonbox.eclass')
-rw-r--r--eclass/commonbox.eclass106
1 files changed, 56 insertions, 50 deletions
diff --git a/eclass/commonbox.eclass b/eclass/commonbox.eclass
index a625fdf2fa90..1194b734f37e 100644
--- a/eclass/commonbox.eclass
+++ b/eclass/commonbox.eclass
@@ -1,7 +1,7 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2
# Author: Seemant Kulleen <seemant@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/commonbox.eclass,v 1.7 2002/09/03 10:48:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/commonbox.eclass,v 1.8 2002/09/04 12:18:42 seemant Exp $
# The commonbox eclass is designed to allow easier installation of the box
# window managers such as blackbox and fluxbox and commonbox
@@ -12,7 +12,7 @@
ECLASS=commonbox
INHERITED="$INHERITED $ECLASS"
-EXPORT_FUNCTIONS src_compile src_install pkg_postinst
+EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_postinst
DEPEND="x11-misc/commonbox-utils
x11-themes/commonbox-styles"
@@ -22,42 +22,47 @@ PROVIDE="virtual/blackbox"
myconf=""
mydoc=""
-MYBIN=""
-commonise=1
+BOOTSTRAP=""
+
+if [ -z "${MYBIN}" ]
+then
+ MYBIN="${PN}"
+fi
+
+commonbox_src_unpack() {
+
+ unpack ${A}
-commonify() {
cd ${S}
+ cp Makefile.am Makefile.am.orig
+ sed 's/data //' Makefile.am.orig > Makefile.am
- cp Makefile Makefile.orig
- sed -e "s:\(SUBDIRS = \).*:\1doc nls src:" \
- Makefile.orig > Makefile
-}
+ cd ${S}/util
+ cp Makefile.am Makefile.am.orig
+ sed -e 's/bsetbg//' \
+ -e 's/bsetroot//' \
+ Makefile.am.orig > Makefile.am
-commondoc() {
- cd ${S}/doc
- cp Makefile Makefile.orig
+ cd ${S}/doc
+ cp Makefile.am Makefile.am.orig
sed -e "s:bsetroot.1::" \
-e "s:bsetbg.1::" \
- Makefile.orig > Makefile
-
- cd ${S}
-}
+ Makefile.am.orig > Makefile.am
-sharedir() {
- cd ${S}/src
- cp Makefile Makefile.orig
-# sed -e 's:$(pkgdatadir)/menu:\\"/usr/share/commonbox/menu\\":' \
-# -e 's:$(pkgdatadir)/styles:\\"/usr/share/commonbox/styles:' \
-# -e 's:\(DEFAULT_INITFILE\).*:\1=\\"/usr/share/commonbox/init\\":' \
-# Makefile.orig > Makefile
-
- cd ${S}
+ einfo ${MYBIN}
}
commonbox_src_compile() {
+ if [ -z "${BOOTSTRAP}" ]
+ then
+ aclocal
+ automake
+ autoconf
+ fi
+
use nls \
&& myconf="${myconf} --enable-nls" \
|| myconf="${myconf} --disable-nls"
@@ -71,19 +76,13 @@ commonbox_src_compile() {
|| myconf="${myconf} --disable-gnome"
econf \
- --sysconfdir=/etc/X11/${PN} \
+ --sysconfdir=/etc/X11/${MYBIN} \
--datadir=/usr/share/commonbox \
${myconf} || die
- if [ ! -z $commonise ]
- then
- commonify || die
- fi
- commondoc || die
- sharedir || die
-
emake \
- pkgdatadir="/usr/share/commonbox" || die
+ pkgdatadir=/usr/share/commonbox/${MYBIN} || die
+
}
@@ -91,19 +90,26 @@ commonbox_src_install() {
dodir /usr/share/commonbox
einstall \
- pkgdatadir="${D}/usr/share/commonbox" || die
+ pkgdatadir=${D}/usr/share/commonbox/${MYBIN} || die
- dodoc README* AUTHORS TODO* ${mydoc}
+ # move the ${PN} binary to ${MYBIN}
- if [ -z "${MYBIN}" ]
+ if [ "${MYBIN}" != "${PN}" ]
then
- MYBIN=${PN}
+ mv ${D}/usr/bin/${PN} ${D}/usr/bin/${MYBIN}
+
+ # same to manpage
+ rm ${D}/usr/share/man/man1/${PN}.1
+ mv doc/${PN}.1 doc/${MYBIN}.1
+ doman doc/${MYBIN}.1
fi
+ dodoc README* AUTHORS TODO* ${mydoc}
+
# move nls stuff
use nls && ( \
dodir /usr/share/commonbox/${MYBIN}
- mv ${D}/usr/share/${MYBIN}/nls ${D}/usr/share/commonbox/${MYBIN}
+ mv ${D}/usr/share/${PN}/nls ${D}/usr/share/commonbox/${MYBIN}
)
rmdir ${D}/usr/share/${MYBIN}
@@ -118,17 +124,17 @@ commonbox_pkg_postinst() {
if [ -d /usr/share/commonbox ]
then
einfo
- einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
- einfo "! ${PN} no longer uses /usr/share/${PN} as the !"
- einfo "! default share directory to contain styles and menus. !"
- einfo "! The default directory is now /usr/share/commonbox !"
- einfo "! Please move any files in /usr/share/${PN} that you !"
- einfo "! wish to keep (personal styles and your menu) into the !"
- einfo "! new directory and modify your menu files to point all !"
- einfo "! listed paths to the new directory. !"
- einfo "! Also, be sure to update the paths in each user's !"
- einfo "! config file found in their home directory. !"
- einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ einfo "! ${MYBIN} no longer uses /usr/share/${MYBIN} as the !"
+ einfo "! default share directory to contain styles and menus. !"
+ einfo "! The default directory is now /usr/share/commonbox !"
+ einfo "! Please move any files in /usr/share/${MYBIN} that you !"
+ einfo "! wish to keep (personal styles and your menu) into the !"
+ einfo "! new directory and modify your menu files to point all !"
+ einfo "! listed paths to the new directory. !"
+ einfo "! Also, be sure to update the paths in each user's !"
+ einfo "! config file found in their home directory. !"
+ einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
einfo
fi
}