summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-05-17 17:43:33 +0000
committerPeter Volkov <pva@gentoo.org>2010-05-17 17:43:33 +0000
commita43c9e149a84d36bd99ee21dd95531b6e505a8c2 (patch)
tree00ab58eb6f92c7b4813f3f70c11d6a6eeac1ceae /dev-vcs
parentamd64 stable, bug #317535 (diff)
downloadgentoo-2-a43c9e149a84d36bd99ee21dd95531b6e505a8c2.tar.gz
gentoo-2-a43c9e149a84d36bd99ee21dd95531b6e505a8c2.tar.bz2
gentoo-2-a43c9e149a84d36bd99ee21dd95531b6e505a8c2.zip
Version bump, bug #309577, thank Jack Lloyd for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/monotone/ChangeLog8
-rw-r--r--dev-vcs/monotone/metadata.xml4
-rw-r--r--dev-vcs/monotone/monotone-0.47.ebuild126
3 files changed, 137 insertions, 1 deletions
diff --git a/dev-vcs/monotone/ChangeLog b/dev-vcs/monotone/ChangeLog
index 42cc09d4d99f..9f1bb27bb808 100644
--- a/dev-vcs/monotone/ChangeLog
+++ b/dev-vcs/monotone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/monotone
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/ChangeLog,v 1.2 2010/04/27 17:30:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/ChangeLog,v 1.3 2010/05/17 17:43:33 pva Exp $
+
+*monotone-0.47 (17 May 2010)
+
+ 17 May 2010; Peter Volkov <pva@gentoo.org> +monotone-0.47.ebuild,
+ metadata.xml:
+ Version bump, bug #309577, thank Jack Lloyd for report.
27 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> monotone-0.45.ebuild,
+files/monotone-0.45-gcc45.patch:
diff --git a/dev-vcs/monotone/metadata.xml b/dev-vcs/monotone/metadata.xml
index 4175e4d93d62..b695e43401ba 100644
--- a/dev-vcs/monotone/metadata.xml
+++ b/dev-vcs/monotone/metadata.xml
@@ -11,6 +11,10 @@
<name>Jonny</name>
<description>Future Maintainer</description>
</maintainer>
+ <maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+ </maintainer>
<longdescription>
A free distributed version control system. It provides a simple,
single-file transactional version store, with fully disconnected
diff --git a/dev-vcs/monotone/monotone-0.47.ebuild b/dev-vcs/monotone/monotone-0.47.ebuild
new file mode 100644
index 000000000000..fc90ff1cee75
--- /dev/null
+++ b/dev-vcs/monotone/monotone-0.47.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/monotone-0.47.ebuild,v 1.1 2010/05/17 17:43:33 pva Exp $
+
+EAPI=2
+inherit bash-completion elisp-common eutils toolchain-funcs
+
+DESCRIPTION="Monotone Distributed Version Control System"
+HOMEPAGE="http://monotone.ca"
+SRC_URI="http://monotone.ca/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc emacs ipv6 nls"
+
+RDEPEND="sys-libs/zlib
+ emacs? ( virtual/emacs )
+ >=dev-libs/libpcre-7.6
+ >=dev-libs/botan-1.8.0
+ >=dev-db/sqlite-3.3.8
+ >=dev-lang/lua-5.1
+ net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.33.1
+ nls? ( >=sys-devel/gettext-0.11.5 )
+ doc? ( sys-apps/texinfo )"
+
+pkg_setup() {
+ enewgroup monotone
+ enewuser monotone -1 -1 /var/lib/monotone monotone
+}
+
+src_prepare() {
+ if [[ $(gcc-major-version) -lt "3" ||
+ ( $(gcc-major-version) -eq "3" && $(gcc-minor-version) -le 3 ) ]]; then
+ die 'requires >=gcc-3.4'
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ --with-system-pcre
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use doc; then
+ emake html || die "emake html failed"
+ fi
+
+ if use emacs; then
+ cd contrib
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ if [ ${UID} != 0 ]; then
+ emake check || die "emake check failed"
+ else
+ ewarn "Tests will fail if ran as root, skipping."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
+
+ dobashcompletion contrib/monotone.bash_completion
+
+ if use doc; then
+ dohtml -r html/*
+ dohtml -r figures
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} contrib/*.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el \
+ || die "elisp-site-file-install failed"
+ fi
+
+ dodoc AUTHORS NEWS README* UPGRADE || die
+ docinto contrib
+ dodoc contrib/*
+ newconfd "${FILESDIR}"/monotone.confd monotone || die
+ newinitd "${FILESDIR}"/${PN}-0.36.initd monotone || die
+
+ insinto /etc/monotone
+ newins "${FILESDIR}"/hooks.lua hooks.lua || die
+ newins "${FILESDIR}"/read-permissions read-permissions || die
+ newins "${FILESDIR}"/write-permissions write-permissions || die
+
+ keepdir /var/lib/monotone/keys/ /var/{log,run}/monotone
+ fowners monotone:monotone /var/lib/monotone{,/keys} /var/{log,run}/monotone
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ elog
+ elog "For details and instructions to upgrade from previous versions,"
+ elog "please read /usr/share/doc/${PF}/UPGRADE.bz2"
+ elog
+ elog " 1. edit /etc/conf.d/monotone"
+ elog " 2. import the first keys to enable access with"
+ elog " env HOME=\${homedir} mtn pubkey me@example.net | /etc/init.d/monotone import"
+ elog " Thereafter, those with write permission can add other keys via"
+ elog " netsync with 'monotone push --key-to-push=IDENT' and then IDENT"
+ elog " can be used in the read-permission and write-permission files."
+ elog " 3. adjust permisions in /etc/monotone/read-permissions"
+ elog " and /etc/monotone/write-permissions"
+ elog " 4. start the daemon: /etc/init.d/monotone start"
+ elog " 5. make persistent: rc-update add monotone default"
+ elog
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}