summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2011-12-15 20:40:48 +0000
committerAgostino Sarubbo <ago@gentoo.org>2011-12-15 20:40:48 +0000
commit1bfb268f8e89081157276fff92114ee9f4358daa (patch)
tree01f0a1d4508965d8be479f416db8e0f5ee26e155 /dev-vcs
parentRemove broken version (diff)
downloadgentoo-2-1bfb268f8e89081157276fff92114ee9f4358daa.tar.gz
gentoo-2-1bfb268f8e89081157276fff92114ee9f4358daa.tar.bz2
gentoo-2-1bfb268f8e89081157276fff92114ee9f4358daa.zip
Added '|| die' where missing, wrt bug #393287
(Portage version: 2.1.10.40/cvs/Linux i686)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/ChangeLog5
-rw-r--r--dev-vcs/mercurial/mercurial-2.0.1.ebuild68
2 files changed, 38 insertions, 35 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index 6082fce6b072..2cbf05664d18 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-vcs/mercurial
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.60 2011/12/14 23:24:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.61 2011/12/15 20:40:48 ago Exp $
+
+ 15 Dec 2011; Agostino Sarubbo <ago@gentoo.org> mercurial-2.0.1.ebuild:
+ Added '|| die' where missing, wrt bug #393287
14 Dec 2011; Markus Meier <maekke@gentoo.org> mercurial-2.0.ebuild:
arm stable, bug #393265
diff --git a/dev-vcs/mercurial/mercurial-2.0.1.ebuild b/dev-vcs/mercurial/mercurial-2.0.1.ebuild
index a6800a5ae491..100a9b85e5aa 100644
--- a/dev-vcs/mercurial/mercurial-2.0.1.ebuild
+++ b/dev-vcs/mercurial/mercurial-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.0.1.ebuild,v 1.1 2011/12/05 11:45:11 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.0.1.ebuild,v 1.2 2011/12/15 20:40:48 ago Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -47,11 +47,11 @@ src_compile() {
distutils_src_compile
if use emacs; then
- cd "${S}"/contrib
+ cd "${S}"/contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
- rm -rf contrib/{win32,macosx}
+ rm -rf contrib/{win32,macosx} || die
}
src_install() {
@@ -61,27 +61,27 @@ src_install() {
if use zsh-completion ; then
insinto /usr/share/zsh/site-functions
- newins contrib/zsh_completion _hg
+ newins contrib/zsh_completion _hg || die
fi
- rm -f doc/*.?.txt
- dodoc CONTRIBUTORS PKG-INFO README doc/*.txt
- cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/
+ rm -f doc/*.?.txt || die
+ dodoc CONTRIBUTORS PKG-INFO README doc/*.txt || die
+ cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
- dobin hgeditor
- dobin contrib/hgk
- dobin contrib/hg-ssh
+ dobin hgeditor || die
+ dobin contrib/hgk || die
+ dobin contrib/hg-ssh || die
- rm -f contrib/hgk contrib/hg-ssh
+ rm -f contrib/hgk contrib/hg-ssh || die
- rm -f contrib/bash_completion
- cp -r contrib "${ED}"/usr/share/doc/${PF}/
- doman doc/*.?
+ rm -f contrib/bash_completion || die
+ cp -r contrib "${ED}"/usr/share/doc/${PF}/ || die
+ doman doc/*.? || die
cat > "${T}/80mercurial" <<-EOF
HG="${EPREFIX}/usr/bin/hg"
EOF
- doenvd "${T}/80mercurial"
+ doenvd "${T}/80mercurial" || die
if use emacs; then
elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
@@ -90,31 +90,31 @@ EOF
}
src_test() {
- cd "${S}/tests/"
- rm -rf *svn* # Subversion tests fail with 1.5
- rm -f test-archive # Fails due to verbose tar output changes
- rm -f test-convert-baz* # GNU Arch baz
- rm -f test-convert-cvs* # CVS
- rm -f test-convert-darcs* # Darcs
- rm -f test-convert-git* # git
- rm -f test-convert-mtn* # monotone
- rm -f test-convert-tla* # GNU Arch tla
- rm -f test-doctest* # doctest always fails with python 2.5.x
+ cd "${S}/tests/" || die
+ rm -rf *svn* || die # Subversion tests fail with 1.5
+ rm -f test-archive || die # Fails due to verbose tar output changes
+ rm -f test-convert-baz* || die # GNU Arch baz
+ rm -f test-convert-cvs* || die # CVS
+ rm -f test-convert-darcs* || die # Darcs
+ rm -f test-convert-git* || die # git
+ rm -f test-convert-mtn* || die # monotone
+ rm -f test-convert-tla* || die # GNU Arch tla
+ rm -f test-doctest* || die # doctest always fails with python 2.5.x
if [[ ${EUID} -eq 0 ]]; then
einfo "Removing tests which require user privileges to succeed"
- rm -f test-command-template # Test is broken when run as root
- rm -f test-convert # Test is broken when run as root
- rm -f test-lock-badness # Test is broken when run as root
- rm -f test-permissions # Test is broken when run as root
- rm -f test-pull-permission # Test is broken when run as root
- rm -f test-clone-failure
- rm -f test-journal-exists
- rm -f test-repair-strip
+ rm -f test-command-template || die # Test is broken when run as root
+ rm -f test-convert || die # Test is broken when run as root
+ rm -f test-lock-badness || die # Test is broken when run as root
+ rm -f test-permissions || die # Test is broken when run as root
+ rm -f test-pull-permission || die # Test is broken when run as root
+ rm -f test-clone-failure || die
+ rm -f test-journal-exists || die
+ rm -f test-repair-strip || die
fi
testing() {
local testdir="${T}/tests-${PYTHON_ABI}"
- rm -rf "${testdir}"
+ rm -rf "${testdir}" || die
"$(PYTHON)" run-tests.py --tmpdir="${testdir}"
}
python_execute_function testing