summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-10-11 20:32:14 +0000
committerMichał Górny <mgorny@gentoo.org>2014-10-11 20:32:14 +0000
commit2f18054e7290ee75949a144a13d7b9d6792a73cf (patch)
tree24b46efc9688bb941a49fc587f39b3768d4d943b /dev-vcs/git
parentStable for HPPA (bug #525038). (diff)
downloadgentoo-2-2f18054e7290ee75949a144a13d7b9d6792a73cf.tar.gz
gentoo-2-2f18054e7290ee75949a144a13d7b9d6792a73cf.tar.bz2
gentoo-2-2f18054e7290ee75949a144a13d7b9d6792a73cf.zip
Install bash completion alias for gitk command, bug #521168.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/ChangeLog6
-rw-r--r--dev-vcs/git/git-2.1.2.ebuild3
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild3
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild3
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild3
-rw-r--r--dev-vcs/git/git-9999.ebuild3
6 files changed, 15 insertions, 6 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index 84e9f3dace1b..d6254609bcbb 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.290 2014/10/05 10:45:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.291 2014/10/11 20:32:14 mgorny Exp $
+
+ 11 Oct 2014; Michał Górny <mgorny@gentoo.org> git-2.1.2.ebuild,
+ git-9999-r1.ebuild, git-9999-r2.ebuild, git-9999-r3.ebuild, git-9999.ebuild:
+ Install bash completion alias for gitk command, bug #521168.
05 Oct 2014; Agostino Sarubbo <ago@gentoo.org> git-2.0.4.ebuild:
Stable for ppc, wrt bug #519736
diff --git a/dev-vcs/git/git-2.1.2.ebuild b/dev-vcs/git/git-2.1.2.ebuild
index 22e8c46c7a1d..bbbc63fb1f99 100644
--- a/dev-vcs/git/git-2.1.2.ebuild
+++ b/dev-vcs/git/git-2.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-2.1.2.ebuild,v 1.1 2014/10/02 08:37:23 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-2.1.2.ebuild,v 1.2 2014/10/11 20:32:14 mgorny Exp $
EAPI=5
@@ -378,6 +378,7 @@ src_install() {
use doc && doinfo Documentation/{git,gitman}.info
newbashcomp contrib/completion/git-completion.bash ${PN}
+ bashcomp_alias git gitk
# Not really a bash-completion file (bug #477920)
# but still needed uncompressed (bug #507480)
insinto /usr/share/${PN}
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 644d79a3d529..eec352bbd322 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild,v 1.6 2014/08/30 08:59:38 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild,v 1.7 2014/10/11 20:32:14 mgorny Exp $
EAPI=5
@@ -378,6 +378,7 @@ src_install() {
use doc && doinfo Documentation/{git,gitman}.info
newbashcomp contrib/completion/git-completion.bash ${PN}
+ bashcomp_alias git gitk
# Not really a bash-completion file (bug #477920)
# but still needed uncompressed (bug #507480)
insinto /usr/share/${PN}
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 913997028fea..a782888dd7b8 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r2.ebuild,v 1.6 2014/08/30 08:59:38 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r2.ebuild,v 1.7 2014/10/11 20:32:14 mgorny Exp $
EAPI=5
@@ -378,6 +378,7 @@ src_install() {
use doc && doinfo Documentation/{git,gitman}.info
newbashcomp contrib/completion/git-completion.bash ${PN}
+ bashcomp_alias git gitk
# Not really a bash-completion file (bug #477920)
# but still needed uncompressed (bug #507480)
insinto /usr/share/${PN}
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index a48881174d76..fae269124ffd 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r3.ebuild,v 1.7 2014/08/30 08:59:38 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r3.ebuild,v 1.8 2014/10/11 20:32:14 mgorny Exp $
EAPI=5
@@ -378,6 +378,7 @@ src_install() {
use doc && doinfo Documentation/{git,gitman}.info
newbashcomp contrib/completion/git-completion.bash ${PN}
+ bashcomp_alias git gitk
# Not really a bash-completion file (bug #477920)
# but still needed uncompressed (bug #507480)
insinto /usr/share/${PN}
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 7062b36b3a3b..9a0646db7e8e 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.61 2014/08/30 08:59:38 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.62 2014/10/11 20:32:14 mgorny Exp $
EAPI=5
@@ -378,6 +378,7 @@ src_install() {
use doc && doinfo Documentation/{git,gitman}.info
newbashcomp contrib/completion/git-completion.bash ${PN}
+ bashcomp_alias git gitk
# Not really a bash-completion file (bug #477920)
# but still needed uncompressed (bug #507480)
insinto /usr/share/${PN}