summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 21:08:46 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 21:08:46 +0000
commitdc2ee323716ecf280acef9e24d0ed719187fb73e (patch)
treea30684293bfd5e3e55aefc9c2f1afa03abdfb26e /dev-vcs/git-bz
parentRemove usage of old pci-db and rely upon >=virtual/udev-196 dependency to bri... (diff)
downloadgentoo-2-dc2ee323716ecf280acef9e24d0ed719187fb73e.tar.gz
gentoo-2-dc2ee323716ecf280acef9e24d0ed719187fb73e.tar.bz2
gentoo-2-dc2ee323716ecf280acef9e24d0ed719187fb73e.zip
Add a new snapshot. Migrate to python-r1.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-vcs/git-bz')
-rw-r--r--dev-vcs/git-bz/ChangeLog8
-rw-r--r--dev-vcs/git-bz/git-bz-0.12.12.15.ebuild25
-rw-r--r--dev-vcs/git-bz/git-bz-9999.ebuild15
3 files changed, 37 insertions, 11 deletions
diff --git a/dev-vcs/git-bz/ChangeLog b/dev-vcs/git-bz/ChangeLog
index f39da9bcb5a9..f86fac563ee3 100644
--- a/dev-vcs/git-bz/ChangeLog
+++ b/dev-vcs/git-bz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git-bz
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bz/ChangeLog,v 1.3 2012/12/15 12:45:45 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bz/ChangeLog,v 1.4 2012/12/15 21:08:46 mgorny Exp $
+
+*git-bz-0.12.12.15 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +git-bz-0.12.12.15.ebuild,
+ git-bz-9999.ebuild:
+ Add a new snapshot. Migrate to python-r1.
*git-bz-9999 (15 Dec 2012)
diff --git a/dev-vcs/git-bz/git-bz-0.12.12.15.ebuild b/dev-vcs/git-bz/git-bz-0.12.12.15.ebuild
new file mode 100644
index 000000000000..ee6cd2cc46fd
--- /dev/null
+++ b/dev-vcs/git-bz/git-bz-0.12.12.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bz/git-bz-0.12.12.15.ebuild,v 1.1 2012/12/15 21:08:46 mgorny Exp $
+
+EAPI=4
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_8,1_9} )
+
+inherit python-r1
+
+DESCRIPTION="Bugzilla subcommand for git"
+HOMEPAGE="http://www.fishsoup.net/software/git-bz/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman ${PN}.1
+ dodoc TODO
+}
diff --git a/dev-vcs/git-bz/git-bz-9999.ebuild b/dev-vcs/git-bz/git-bz-9999.ebuild
index 1cba8fbc833c..308e2186c34c 100644
--- a/dev-vcs/git-bz/git-bz-9999.ebuild
+++ b/dev-vcs/git-bz/git-bz-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bz/git-bz-9999.ebuild,v 1.1 2012/12/15 12:45:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bz/git-bz-9999.ebuild,v 1.2 2012/12/15 21:08:46 mgorny Exp $
EAPI=4
-PYTHON_DEPEND=2
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_8,1_9} )
-inherit python
+inherit python-r1
#if LIVE
EGIT_REPO_URI="git://git.fishsoup.net/${PN}
@@ -32,18 +32,13 @@ DEPEND="app-text/asciidoc
KEYWORDS=
SRC_URI=
-src_prepare() {
- python_convert_shebangs 2 ${PN}
+src_compile() {
emake ${PN}.1
}
#endif
-src_compile() {
- :
-}
-
src_install() {
- dobin ${PN}
+ python_foreach_impl python_doscript ${PN}
doman ${PN}.1
dodoc TODO
}