summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2014-11-20 18:52:26 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2014-11-20 18:52:26 +0000
commitb04442054b1773bc998c97d5c02026a606ce396d (patch)
tree49669ff845f644225ece14432c726bec45afbbd2 /dev-vcs/fossil
parentversion bump (diff)
downloadgentoo-2-b04442054b1773bc998c97d5c02026a606ce396d.tar.gz
gentoo-2-b04442054b1773bc998c97d5c02026a606ce396d.tar.bz2
gentoo-2-b04442054b1773bc998c97d5c02026a606ce396d.zip
Version bump. Add ~arm. Clean out old. Fixes bug 521910. Thanks
David Flogeras. (Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'dev-vcs/fossil')
-rw-r--r--dev-vcs/fossil/ChangeLog9
-rw-r--r--dev-vcs/fossil/fossil-20140612172556.ebuild (renamed from dev-vcs/fossil/fossil-20130216000435.ebuild)27
2 files changed, 24 insertions, 12 deletions
diff --git a/dev-vcs/fossil/ChangeLog b/dev-vcs/fossil/ChangeLog
index a0d493f8d3d4..e66a7bdaa893 100644
--- a/dev-vcs/fossil/ChangeLog
+++ b/dev-vcs/fossil/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/fossil
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.20 2014/09/01 16:41:42 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.21 2014/11/20 18:52:26 titanofold Exp $
+
+*fossil-20140612172556 (20 Nov 2014)
+
+ 20 Nov 2014; Aaron W. Swenson <titanofold@gentoo.org>
+ -fossil-20130216000435.ebuild, +fossil-20140612172556.ebuild:
+ Version bump. Add ~arm. Clean out old. Fixes bug 521910. Thanks
+ David Flogeras.
01 Sep 2014; Michał Górny <mgorny@gentoo.org> fossil-20130911114349.ebuild:
Remove := subslot operator from || () block since it is meaningless and
diff --git a/dev-vcs/fossil/fossil-20130216000435.ebuild b/dev-vcs/fossil/fossil-20140612172556.ebuild
index 52bd8e6b5dcd..f3c3a889faa8 100644
--- a/dev-vcs/fossil/fossil-20130216000435.ebuild
+++ b/dev-vcs/fossil/fossil-20140612172556.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20130216000435.ebuild,v 1.3 2013/07/04 12:16:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20140612172556.ebuild,v 1.1 2014/11/20 18:52:26 titanofold Exp $
-EAPI="4"
+EAPI=5
+MY_P=${PN}-src-${PV}
-MY_P="${PN}-src-${PV}"
+inherit toolchain-funcs
DESCRIPTION="Simple, high-reliability, source control management, and more"
HOMEPAGE="http://www.fossil-scm.org/"
@@ -12,28 +13,32 @@ SRC_URI="http://www.fossil-scm.org/download/${MY_P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="json -sqlite +ssl tcl"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="json +lineedit sqlite +ssl tcl"
DEPEND="sys-libs/zlib
+ lineedit? ( || ( sys-libs/readline:0 dev-libs/libedit ) )
ssl? ( dev-libs/openssl )
sqlite? ( dev-db/sqlite:3 )
tcl? ( dev-lang/tcl )
"
-
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_configure() {
+ # this is not an autotools situation so don't make it seem like one
# --with-tcl: works
# --without-tcl: dies
- local myconf='--with-zlib --markdown'
+ local myconf='--with-zlib'
+
+ myconf+=" --lineedit=$(usex lineedit 1 0)"
+ myconf+=" --with-openssl=$(usex ssl auto none)"
use json && myconf+=' --json'
use sqlite && myconf+=' --disable-internal-sqlite'
- use ssl && myconf+=' --with-openssl'
use tcl && myconf+=' --with-tcl --with-tcl-stubs'
- econf ${myconf}
+ tc-export CC
+ ./configure ${myconf} || die
}
src_install() {