summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2009-10-23 19:17:40 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2009-10-23 19:17:40 +0000
commitf9d97239222186206746af408c6f137872111ff8 (patch)
treefae0d63d099b3349d2cd18075874e6ef985a0dfa /dev-util
parentVersion bump. (diff)
downloadgentoo-2-f9d97239222186206746af408c6f137872111ff8.tar.gz
gentoo-2-f9d97239222186206746af408c6f137872111ff8.tar.bz2
gentoo-2-f9d97239222186206746af408c6f137872111ff8.zip
Fix two problems preventing compilation of valgrind-3.5.0 on ppc32/ppc64 (bug #289892).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/files/valgrind-3.5.0-local-labels.patch26
-rw-r--r--dev-util/valgrind/valgrind-3.5.0.ebuild12
3 files changed, 37 insertions, 9 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index 3bed503f58ae..55124c6567ae 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valgrind
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.106 2009/10/14 18:50:59 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.107 2009/10/23 19:17:39 griffon26 Exp $
+
+ 23 Oct 2009; Maurice van der Pot <griffon26@gentoo.org>
+ valgrind-3.5.0.ebuild, +files/valgrind-3.5.0-local-labels.patch:
+ Removed now unnecessary patch for no-multilib ppc64 and valgrind-3.5.0, as it
+ failed to apply (bug #289892 by Alexis Ballier <aballier@gentoo.org>). Added
+ another local labels patch to make things compile on ppc32 and ppc64.
*valgrind-3.5.0 (14 Oct 2009)
diff --git a/dev-util/valgrind/files/valgrind-3.5.0-local-labels.patch b/dev-util/valgrind/files/valgrind-3.5.0-local-labels.patch
new file mode 100644
index 000000000000..70e559a12edd
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.5.0-local-labels.patch
@@ -0,0 +1,26 @@
+Index: coregrind/m_libcassert.c
+===================================================================
+--- coregrind/m_libcassert.c (revision 10904)
++++ coregrind/m_libcassert.c (working copy)
+@@ -65,8 +65,8 @@
+ #elif defined(VGP_ppc32_linux) || defined(VGP_ppc32_aix5)
+ # define GET_REAL_PC_SP_AND_FP(pc, sp, fp) \
+ asm("mflr 0;" /* r0 = lr */ \
+- "bl m_libcassert_get_ip;" /* lr = pc */ \
+- "m_libcassert_get_ip:\n" \
++ "bl 0f;" /* lr = pc */ \
++ "0:\n" \
+ "mflr %0;" \
+ "mtlr 0;" /* restore lr */ \
+ "mr %1,1;" \
+@@ -79,8 +79,8 @@
+ #elif defined(VGP_ppc64_linux) || defined(VGP_ppc64_aix5)
+ # define GET_REAL_PC_SP_AND_FP(pc, sp, fp) \
+ asm("mflr 0;" /* r0 = lr */ \
+- "bl .m_libcassert_get_ip;" /* lr = pc */ \
+- ".m_libcassert_get_ip:\n" \
++ "bl 0f;" /* lr = pc */ \
++ "0:\n" \
+ "mflr %0;" \
+ "mtlr 0;" /* restore lr */ \
+ "mr %1,1;" \
diff --git a/dev-util/valgrind/valgrind-3.5.0.ebuild b/dev-util/valgrind/valgrind-3.5.0.ebuild
index 492db72cf660..63e25a93a046 100644
--- a/dev-util/valgrind/valgrind-3.5.0.ebuild
+++ b/dev-util/valgrind/valgrind-3.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.5.0.ebuild,v 1.1 2009/10/14 18:50:59 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.5.0.ebuild,v 1.2 2009/10/23 19:17:39 griffon26 Exp $
inherit autotools eutils flag-o-matic toolchain-funcs
@@ -32,13 +32,6 @@ src_unpack() {
# Correct hard coded doc location
sed -i -e "s:doc/valgrind:doc/${P}:" docs/Makefile.am
- # Remove defaulting to ppc32-linux on ppc64 without multilib
- # "valgrind: failed to start tool 'memcheck' for platform 'ppc32-linux':
- # No such file or directory"
- if use ppc64 && ! has_multilib_profile; then
- epatch "${FILESDIR}/valgrind-3.3.0-only64bit.patch"
- fi
-
# Fix up some suppressions that were not general enough for glibc versions
# with more than just a major and minor number.
epatch "${FILESDIR}/valgrind-3.4.1-glibc-2.10.1.patch"
@@ -46,6 +39,9 @@ src_unpack() {
# Respect LDFLAGS also for libmpiwrap.so (bug #279194)
epatch "${FILESDIR}/valgrind-3.5.0-respect-LDFLAGS.patch"
+ # Yet more local labels, this time for ppc32 & ppc64
+ epatch "${FILESDIR}/valgrind-3.5.0-local-labels.patch"
+
# Regenerate autotools files
eautoreconf
}