summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-08 08:14:29 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-08 08:14:29 +0000
commitd7df588297cbd6ee311607c184699bdbb63b251a (patch)
treeee41b34529196df3e8d229283070059beadb3557 /dev-util
parentUse udev.pc pkg-config file to determine correct install path for 70-infrared... (diff)
downloadgentoo-2-d7df588297cbd6ee311607c184699bdbb63b251a.tar.gz
gentoo-2-d7df588297cbd6ee311607c184699bdbb63b251a.tar.bz2
gentoo-2-d7df588297cbd6ee311607c184699bdbb63b251a.zip
dev-util/httpup: Fix for compilation with gcc-4.7, #430338
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/httpup/ChangeLog8
-rw-r--r--dev-util/httpup/files/httpup-0.4.0k-gcc-4.7.patch15
-rw-r--r--dev-util/httpup/httpup-0.4.0k.ebuild17
-rw-r--r--dev-util/httpup/metadata.xml6
4 files changed, 32 insertions, 14 deletions
diff --git a/dev-util/httpup/ChangeLog b/dev-util/httpup/ChangeLog
index 14b8eea8eeb8..455405fe22e2 100644
--- a/dev-util/httpup/ChangeLog
+++ b/dev-util/httpup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/httpup
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/ChangeLog,v 1.10 2010/05/22 17:42:17 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/ChangeLog,v 1.11 2012/08/08 08:14:29 jlec Exp $
+
+ 08 Aug 2012; Justin Lecher <jlec@gentoo.org> httpup-0.4.0k.ebuild,
+ +files/httpup-0.4.0k-gcc-4.7.patch, metadata.xml:
+ Fix for compilation with gcc-4.7, #430338
22 May 2010; Fabian Groffen <grobian@gentoo.org> httpup-0.4.0k.ebuild:
Fix ebuild for Prefix, bump to EAPI=3
diff --git a/dev-util/httpup/files/httpup-0.4.0k-gcc-4.7.patch b/dev-util/httpup/files/httpup-0.4.0k-gcc-4.7.patch
new file mode 100644
index 000000000000..c015cecaf538
--- /dev/null
+++ b/dev-util/httpup/files/httpup-0.4.0k-gcc-4.7.patch
@@ -0,0 +1,15 @@
+ main.cpp | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/main.cpp b/main.cpp
+index 3040b9d..2d807ed 100644
+--- a/main.cpp
++++ b/main.cpp
+@@ -12,6 +12,7 @@
+ #include <iostream>
+ #include <string>
+ #include <cstdlib>
++#include <unistd.h>
+ using namespace std;
+
+ #include "httpup.h"
diff --git a/dev-util/httpup/httpup-0.4.0k.ebuild b/dev-util/httpup/httpup-0.4.0k.ebuild
index 595d63ff49b1..66000929b35e 100644
--- a/dev-util/httpup/httpup-0.4.0k.ebuild
+++ b/dev-util/httpup/httpup-0.4.0k.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/httpup-0.4.0k.ebuild,v 1.2 2010/05/22 17:42:17 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/httpup-0.4.0k.ebuild,v 1.3 2012/08/08 08:14:29 jlec Exp $
+
+EAPI=4
-EAPI="3"
inherit eutils toolchain-funcs
DESCRIPTION="synchronisation tool for http file repositories"
@@ -17,17 +18,15 @@ IUSE=""
DEPEND="net-misc/curl"
src_prepare() {
- epatch "${FILESDIR}"/${P}-Makefile.patch
-}
-
-src_compile() {
+ epatch \
+ "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-gcc-4.7.patch
tc-export CC CXX
- emake || die
}
src_install() {
emake DESTDIR="${D}" \
mandir="${EPREFIX}/usr/share/man" \
- prefix="${EPREFIX}/usr" install || die
+ prefix="${EPREFIX}/usr" install
dodoc AUTHORS ChangeLog httpup.conf.example README TODO
}
diff --git a/dev-util/httpup/metadata.xml b/dev-util/httpup/metadata.xml
index d9cd2cad66c2..91f4e72fb544 100644
--- a/dev-util/httpup/metadata.xml
+++ b/dev-util/httpup/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
-<email>maintainer-needed@gentoo.org</email>
-</maintainer>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
</pkgmetadata>