summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 18:10:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 18:10:12 +0000
commita359dde96ebae607afebe07e362c5d9da4c3a3ee (patch)
tree7c98bc9ce492bbd325e881eaba63600b3953e2ce /dev-util
parentAdjust deps; make users happy =) (diff)
downloadgentoo-2-a359dde96ebae607afebe07e362c5d9da4c3a3ee.tar.gz
gentoo-2-a359dde96ebae607afebe07e362c5d9da4c3a3ee.tar.bz2
gentoo-2-a359dde96ebae607afebe07e362c5d9da4c3a3ee.zip
Bump to 0.11, closes #256339
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/svn2cl/ChangeLog9
-rw-r--r--dev-util/svn2cl/svn2cl-0.11.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-util/svn2cl/ChangeLog b/dev-util/svn2cl/ChangeLog
index e553d6ae0621..4fc3bea95326 100644
--- a/dev-util/svn2cl/ChangeLog
+++ b/dev-util/svn2cl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/svn2cl
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/svn2cl/ChangeLog,v 1.6 2008/11/15 12:08:04 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/svn2cl/ChangeLog,v 1.7 2009/03/01 18:10:12 patrick Exp $
+
+*svn2cl-0.11 (01 Mar 2009)
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org> +svn2cl-0.11.ebuild:
+ Bump to 0.11, closes #256339
15 Nov 2008; Markus Meier <maekke@gentoo.org> svn2cl-0.9.ebuild:
amd64/x86 stable, bug #228987
diff --git a/dev-util/svn2cl/svn2cl-0.11.ebuild b/dev-util/svn2cl/svn2cl-0.11.ebuild
new file mode 100644
index 000000000000..46ddd4bfdb66
--- /dev/null
+++ b/dev-util/svn2cl/svn2cl-0.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/svn2cl/svn2cl-0.11.ebuild,v 1.1 2009/03/01 18:10:12 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output"
+HOMEPAGE="http://ch.tudelft.nl/~arthur/svn2cl/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxslt
+ dev-util/subversion"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # the wrapper script looks for the xsl files in the
+ # same directory as the script.
+ epatch "${FILESDIR}"/0.9-wrapper.patch
+}
+
+src_install() {
+ newbin svn2cl.sh svn2cl || die "failed to install wrapper script"
+ insinto /usr/share/svn2cl
+ doins svn2cl.xsl svn2html.xsl || die
+ dodoc README NEWS TODO ChangeLog authors.xml svn2html.css || die
+ doman svn2cl.1 || die
+}
+
+pkg_postinst() {
+ einfo "You can find samples of svn2html.css and authors.xml in"
+ einfo "/usr/share/doc/${PF}/"
+ einfo "Read man page for details."
+}