summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-02-16 13:26:59 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-02-16 13:26:59 +0000
commita2baa739ad571952ce94185693b04eb0bebd51af (patch)
tree3abdc95de4c950edd2784a7ae96bcc560bc0578b /dev-util
parentFix bug 454274 app-office/libreoffice-4.0.0.3: fails to build with dev-libs/b... (diff)
downloadgentoo-2-a2baa739ad571952ce94185693b04eb0bebd51af.tar.gz
gentoo-2-a2baa739ad571952ce94185693b04eb0bebd51af.tar.bz2
gentoo-2-a2baa739ad571952ce94185693b04eb0bebd51af.zip
Took maintainership. Version bump to 0.9.8. Removed epatch call since it was applied upstream, disabled werror, switched to EAPI 5.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/oprofile/ChangeLog9
-rw-r--r--dev-util/oprofile/metadata.xml8
-rw-r--r--dev-util/oprofile/oprofile-0.9.8.ebuild74
3 files changed, 87 insertions, 4 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 8dc4a41aba43..023d3c874d0f 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/oprofile
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.83 2013/02/16 12:38:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.84 2013/02/16 13:26:59 tomwij Exp $
+
+*oprofile-0.9.8 (16 Feb 2013)
+
+ 16 Feb 2013; Tom Wijsman <TomWij@gentoo.org> +oprofile-0.9.8.ebuild,
+ metadata.xml:
+ Took maintainership. Version bump to 0.9.8. Removed epatch call since it was
+ applied upstream, disabled werror, switched to EAPI 5.
16 Feb 2013; Pacho Ramos <pacho@gentoo.org> -oprofile-0.9.6.ebuild,
metadata.xml:
diff --git a/dev-util/oprofile/metadata.xml b/dev-util/oprofile/metadata.xml
index a40624fba8f0..89a25b3b5c4f 100644
--- a/dev-util/oprofile/metadata.xml
+++ b/dev-util/oprofile/metadata.xml
@@ -1,7 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>maintainer-needed@gentoo.org</email>
-</maintainer>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+ <longdescription>A transparent low-overhead system-wide profiler</longdescription>
</pkgmetadata>
diff --git a/dev-util/oprofile/oprofile-0.9.8.ebuild b/dev-util/oprofile/oprofile-0.9.8.ebuild
new file mode 100644
index 000000000000..3e1e71f46ee3
--- /dev/null
+++ b/dev-util/oprofile/oprofile-0.9.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.8.ebuild,v 1.1 2013/02/16 13:26:59 tomwij Exp $
+
+EAPI=5
+inherit eutils linux-info multilib user java-pkg-opt-2
+
+MY_P=${PN}-${PV/_/-}
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://${PN}.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="java pch qt4"
+
+DEPEND=">=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt4? ( x11-libs/qt-gui:4[qt3support] )
+ java? ( >=virtual/jdk-1.5 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_config_exists || ! linux_chkconfig_present OPROFILE ; then
+ echo
+ elog "In order for ${PN} to work, you need to configure your kernel"
+ elog "with CONFIG_OPROFILE set to 'm' or 'y'."
+ echo
+ fi
+
+ if ! kernel_is -ge 2 6 ; then
+ echo
+ elog "Support for kernels before 2.6 has been dropped in ${PN}-0.9.8."
+ echo
+ fi
+
+ # Required for JIT support, see README_PACKAGERS
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+
+ use java && java-pkg_init
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_with qt4 x) \
+ $(use_enable qt4 gui qt4) \
+ $(use_enable pch) \
+ $(use_with java java ${JAVA_HOME})
+}
+
+src_install() {
+ emake DESTDIR="${D}" htmldir="/usr/share/doc/${PF}" install
+
+ dodoc ChangeLog* README TODO
+
+ dodir /etc/env.d
+ echo "LDPATH=${PREFIX}/usr/$(get_libdir)/${PN}" > "${D}"/etc/env.d/10${PN} || die "env.d failed"
+}
+
+pkg_postinst() {
+ echo
+ elog "Now load the ${PN} module by running:"
+ elog " # opcontrol --init"
+ elog "Then read manpages and this html doc:"
+ elog " /usr/share/doc/${PF}/${PN}.html"
+ echo
+}