summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-06 15:35:23 +0000
committerJustin Lecher <jlec@gentoo.org>2015-08-06 15:35:23 +0000
commit7d3947ab88eaeed0a27696860c936297750e9008 (patch)
tree3c8e17fb9fba0c735c09405f21849be93220ad14 /dev-util
parentRemove java-virtuals/javamail and replace it with oracle-javamail. Fixed bug ... (diff)
downloadgentoo-2-7d3947ab88eaeed0a27696860c936297750e9008.tar.gz
gentoo-2-7d3947ab88eaeed0a27696860c936297750e9008.tar.bz2
gentoo-2-7d3947ab88eaeed0a27696860c936297750e9008.zip
Fix for format-security, bug #556846
Signed-off-by: Justin Lecher <jlec@gentoo.org> (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/patchutils/ChangeLog6
-rw-r--r--dev-util/patchutils/files/patchutils-0.3.3-format-security.patch25
-rw-r--r--dev-util/patchutils/patchutils-0.3.3.ebuild10
3 files changed, 38 insertions, 3 deletions
diff --git a/dev-util/patchutils/ChangeLog b/dev-util/patchutils/ChangeLog
index 171a31be14b9..3c98eac91cf5 100644
--- a/dev-util/patchutils/ChangeLog
+++ b/dev-util/patchutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/patchutils
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/patchutils/ChangeLog,v 1.83 2015/07/30 18:05:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/patchutils/ChangeLog,v 1.84 2015/08/06 15:35:23 jlec Exp $
+
+ 06 Aug 2015; Justin Lecher <jlec@gentoo.org>
+ +files/patchutils-0.3.3-format-security.patch, patchutils-0.3.3.ebuild:
+ Fix for format-security, bug #556846
30 Jul 2015; Justin Lecher <jlec@gentoo.org> -patchutils-0.3.2.ebuild:
Drop old
diff --git a/dev-util/patchutils/files/patchutils-0.3.3-format-security.patch b/dev-util/patchutils/files/patchutils-0.3.3-format-security.patch
new file mode 100644
index 000000000000..be190b65a734
--- /dev/null
+++ b/dev-util/patchutils/files/patchutils-0.3.3-format-security.patch
@@ -0,0 +1,25 @@
+ src/filterdiff.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/filterdiff.c b/src/filterdiff.c
+index eb08d49..0b2b301 100644
+--- a/src/filterdiff.c
++++ b/src/filterdiff.c
+@@ -1263,7 +1263,7 @@ read_regex_file (const char *file)
+ char errstr[300];
+ regerror (err, &regex[num_regex - 1], errstr,
+ sizeof (errstr));
+- error (EXIT_FAILURE, 0, errstr);
++ error (EXIT_FAILURE, 0, "%s", errstr);
+ exit (1);
+ }
+ }
+@@ -1509,7 +1509,7 @@ int main (int argc, char *argv[])
+ char errstr[300];
+ regerror (err, &regex[num_regex - 1], errstr,
+ sizeof (errstr));
+- error (EXIT_FAILURE, 0, errstr);
++ error (EXIT_FAILURE, 0, "%s", errstr);
+ exit (1);
+ }
+ }
diff --git a/dev-util/patchutils/patchutils-0.3.3.ebuild b/dev-util/patchutils/patchutils-0.3.3.ebuild
index 92818aa11179..94777ee9dbb8 100644
--- a/dev-util/patchutils/patchutils-0.3.3.ebuild
+++ b/dev-util/patchutils/patchutils-0.3.3.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/patchutils/patchutils-0.3.3.ebuild,v 1.11 2015/07/30 13:09:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/patchutils/patchutils-0.3.3.ebuild,v 1.12 2015/08/06 15:35:23 jlec Exp $
-EAPI=4
+EAPI=5
+
+inherit eutils
DESCRIPTION="A collection of tools that operate on patch files"
HOMEPAGE="http://cyberelk.net/tim/patchutils/"
@@ -17,3 +19,7 @@ RDEPEND=""
# The testsuite makes use of gendiff(1) that comes from rpm, thus if
# the user wants to run tests, it should install that too.
DEPEND="test? ( app-arch/rpm )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}