summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2010-04-14 10:31:30 +0000
committerMarkus Ullmann <jokey@gentoo.org>2010-04-14 10:31:30 +0000
commit39414a26a5ba6d3931c50a663783cbfb56f61d21 (patch)
tree7fca1f4cb5e471e276f0524c292a01b0cfa7937e /dev-util
parentAdd myself as maintainer (diff)
downloadgentoo-2-39414a26a5ba6d3931c50a663783cbfb56f61d21.tar.gz
gentoo-2-39414a26a5ba6d3931c50a663783cbfb56f61d21.tar.bz2
gentoo-2-39414a26a5ba6d3931c50a663783cbfb56f61d21.zip
Version bump, add notice where to find dictionaries
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/skipfish/ChangeLog7
-rw-r--r--dev-util/skipfish/skipfish-1.31_beta.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-util/skipfish/ChangeLog b/dev-util/skipfish/ChangeLog
index 92b2279c015a..99c88745b17f 100644
--- a/dev-util/skipfish/ChangeLog
+++ b/dev-util/skipfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/skipfish
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.4 2010/03/30 18:24:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.5 2010/04/14 10:31:30 jokey Exp $
+
+*skipfish-1.31_beta (14 Apr 2010)
+
+ 14 Apr 2010; Markus Ullmann <jokey@gentoo.org> +skipfish-1.31_beta.ebuild:
+ Version bump, add notice where to find dictionaries
*skipfish-1.27_beta (30 Mar 2010)
diff --git a/dev-util/skipfish/skipfish-1.31_beta.ebuild b/dev-util/skipfish/skipfish-1.31_beta.ebuild
new file mode 100644
index 000000000000..9da4ada5e58c
--- /dev/null
+++ b/dev-util/skipfish/skipfish-1.31_beta.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/skipfish-1.31_beta.ebuild,v 1.1 2010/04/14 10:31:30 jokey Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="A fully automated, active web application security reconnaissance tool"
+HOMEPAGE="http://code.google.com/p/skipfish/"
+SRC_URI="http://${PN}.googlecode.com/files/${P/_beta/b}.tgz"
+
+LICENSE="Apache-2.0 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/openssl
+ net-dns/libidn
+ sys-libs/zlib"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS_GEN/s:-g -ggdb::' \
+ -e '/CFLAGS_OPT/s:-O3::' \
+ Makefile || die
+
+ sed -i \
+ -e "/ASSETS_DIR/s:assets:/usr/share/doc/${PF}/html:" \
+ config.h || die
+}
+
+src_compile() {
+ tc-export CC
+
+ local _debug
+ use debug && _debug=debug
+
+ emake ${_debug} || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1 || die
+
+ elog "Installing dictionaries into /usr/share/${PN}/dictionaries"
+ elog "Remember to copy them to a local directory or use -V"
+ elog "Please take a look at README-FIRST for an introduction"
+ elog "if you are new to this tool."
+ insinto /usr/share/${PN}/dictionaries
+ doins dictionaries/*.wl || die
+
+ dohtml assets/* || die
+
+ dodoc ChangeLog dictionaries/README-FIRST README
+}