summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-07-05 21:46:18 +0000
committerUlrich Müller <ulm@gentoo.org>2012-07-05 21:46:18 +0000
commit251032865e915b8ad8f5053e95e1d7a915f256b9 (patch)
tree6158047754eeb54374ccd4fffb0d0ccb77c932bd /dev-util
parentmarked x86 per bug 424944 (diff)
downloadgentoo-2-251032865e915b8ad8f5053e95e1d7a915f256b9.tar.gz
gentoo-2-251032865e915b8ad8f5053e95e1d7a915f256b9.tar.bz2
gentoo-2-251032865e915b8ad8f5053e95e1d7a915f256b9.zip
Version bump.
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cscope/ChangeLog7
-rw-r--r--dev-util/cscope/cscope-15.7a-r1.ebuild4
-rw-r--r--dev-util/cscope/cscope-15.8.ebuild63
3 files changed, 71 insertions, 3 deletions
diff --git a/dev-util/cscope/ChangeLog b/dev-util/cscope/ChangeLog
index f7342a9f7e05..f68d5bf7c83b 100644
--- a/dev-util/cscope/ChangeLog
+++ b/dev-util/cscope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cscope
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.129 2012/04/26 16:47:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.130 2012/07/05 21:46:18 ulm Exp $
+
+*cscope-15.8 (05 Jul 2012)
+
+ 05 Jul 2012; Ulrich Müller <ulm@gentoo.org> +cscope-15.8.ebuild:
+ Version bump.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> cscope-15.7a-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-util/cscope/cscope-15.7a-r1.ebuild b/dev-util/cscope/cscope-15.7a-r1.ebuild
index 840e5d40c3d1..c4cec761d6a8 100644
--- a/dev-util/cscope/cscope-15.7a-r1.ebuild
+++ b/dev-util/cscope/cscope-15.7a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.7a-r1.ebuild,v 1.11 2012/04/26 16:47:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.7a-r1.ebuild,v 1.12 2012/07/05 21:46:18 ulm Exp $
EAPI=4
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/cscope/${P}.tar.bz2"
LICENSE="BSD GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
IUSE="emacs"
RDEPEND=">=sys-libs/ncurses-5.2
diff --git a/dev-util/cscope/cscope-15.8.ebuild b/dev-util/cscope/cscope-15.8.ebuild
new file mode 100644
index 000000000000..f9f4c49e4bb4
--- /dev/null
+++ b/dev-util/cscope/cscope-15.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.8.ebuild,v 1.1 2012/07/05 21:46:18 ulm Exp $
+
+EAPI=4
+
+inherit autotools elisp-common eutils
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="http://cscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cscope/${P}.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-15.7a-ocs-sysdir.patch" #269305
+ eautoreconf # prevent maintainer mode later on
+}
+
+src_compile() {
+ emake
+ if use emacs; then
+ cd "${S}"/contrib/xcscope || die
+ elisp-compile *.el || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog.old ChangeLog NEWS README TODO
+
+ if use emacs; then
+ cd "${S}"/contrib/xcscope || die
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dobin cscope-indexer
+ fi
+
+ cd "${S}"/contrib/webcscope || die
+ docinto webcscope
+ dodoc INSTALL TODO cgi-lib.pl cscope hilite.c
+ docinto webcscope/icons
+ dodoc icons/*.gif
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}