summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-15 21:54:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-15 21:54:39 +0000
commit8109fb99c90a2d716d87398328153433b655786b (patch)
tree5a9f346b14f76d1bd7f566150e76774996d4a931 /dev-util/xmingw-gcc
parentdon't assign to P; use epatch; error messages (Manifest recommit) (diff)
downloadgentoo-2-8109fb99c90a2d716d87398328153433b655786b.tar.gz
gentoo-2-8109fb99c90a2d716d87398328153433b655786b.tar.bz2
gentoo-2-8109fb99c90a2d716d87398328153433b655786b.zip
don't assign to P; use emake; error messages; tidy
Diffstat (limited to 'dev-util/xmingw-gcc')
-rw-r--r--dev-util/xmingw-gcc/ChangeLog8
-rw-r--r--dev-util/xmingw-gcc/xmingw-gcc-3.3.1.ebuild47
2 files changed, 34 insertions, 21 deletions
diff --git a/dev-util/xmingw-gcc/ChangeLog b/dev-util/xmingw-gcc/ChangeLog
index e6f5df9fa388..5db4f8442ba7 100644
--- a/dev-util/xmingw-gcc/ChangeLog
+++ b/dev-util/xmingw-gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/xmingw-gcc
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-gcc/ChangeLog,v 1.1 2003/10/02 10:19:39 cretin Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-gcc/ChangeLog,v 1.2 2004/03/15 21:54:39 mr_bones_ Exp $
+
+ 15 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ xmingw-gcc-3.3.1.ebuild:
+ don't assign to P; use emake; error messages; tidy
* xmingw-gcc-3.3.1 (01 Oct 2003)
diff --git a/dev-util/xmingw-gcc/xmingw-gcc-3.3.1.ebuild b/dev-util/xmingw-gcc/xmingw-gcc-3.3.1.ebuild
index 071e11553801..4b6c816031c8 100644
--- a/dev-util/xmingw-gcc/xmingw-gcc-3.3.1.ebuild
+++ b/dev-util/xmingw-gcc/xmingw-gcc-3.3.1.ebuild
@@ -1,18 +1,16 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-gcc/xmingw-gcc-3.3.1.ebuild,v 1.2 2003/10/28 19:52:23 cretin Exp $
-
-DESCRIPTION="The GNU Compiler Collection - i386-mingw32msvc-gcc only"
-
-HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
-
-P=${P/xmingw-/}
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-gcc/xmingw-gcc-3.3.1.ebuild,v 1.3 2004/03/15 21:54:39 mr_bones_ Exp $
+MY_P=${P/xmingw-/}
+S=${WORKDIR}/${MY_P}
MINGW_PATCH=gcc-3.3.1-20030804-1-src.diff.gz
RUNTIME=mingw-runtime-3.2
W32API=w32api-2.4
-SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.bz2
+DESCRIPTION="The GNU Compiler Collection - i386-mingw32msvc-gcc only"
+HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${MY_P}/${MY_P}.tar.bz2
mirror://sourceforge/mingw/${MINGW_PATCH}
mirror://sourceforge/mingw/${RUNTIME}-src.tar.gz
mirror://sourceforge/mingw/${W32API}-src.tar.gz"
@@ -21,15 +19,11 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="dev-util/xmingw-binutils"
-S=${WORKDIR}/${P}
-
-export PATH=$PATH:/opt/xmingw/bin:/opt/xmingw/i386-mingw32msvc/bin
-unset CFLAGS CXXFLAGS
+DEPEND="dev-util/xmingw-binutils"
src_unpack() {
- unpack ${P}.tar.bz2
+ unpack ${MY_P}.tar.bz2
unpack ${RUNTIME}-src.tar.gz
unpack ${W32API}-src.tar.gz
cd ${S}; gzip -dc ${DISTDIR}/${MINGW_PATCH} | patch -p1
@@ -41,7 +35,8 @@ src_unpack() {
}
src_compile() {
- cd ${S}
+ export PATH=$PATH:/opt/xmingw/bin:/opt/xmingw/i386-mingw32msvc/bin
+ unset CFLAGS CXXFLAGS
if has_version dev-util/xmingw-runtime \
&& has_version dev-util/xmingw-w32api
then
@@ -50,11 +45,25 @@ src_compile() {
lang=c
fi
- ./configure --target=i386-mingw32msvc --prefix=/opt/xmingw --enable-languages=${lang} --disable-shared --disable-nls --enable-threads --with-gcc --with-gnu-ld --with-gnu-as --disable-win32-registry --enable-sjlj-exceptions --without-x --without-newlib || die
+ ./configure \
+ --target=i386-mingw32msvc \
+ --prefix=/opt/xmingw \
+ --enable-languages=${lang} \
+ --disable-shared \
+ --disable-nls \
+ --enable-threads \
+ --with-gcc \
+ --with-gnu-ld \
+ --with-gnu-as \
+ --disable-win32-registry \
+ --enable-sjlj-exceptions \
+ --without-x \
+ --without-newlib \
+ || die "configure failed"
- make || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
}