summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-07-05 05:05:04 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-07-05 05:05:04 +0000
commit34da6ce4535c6285ecf97af2cc9d2e3c58d39a7f (patch)
tree78b4685745dd8ae3507569c0595fbcb9eba5db88 /dev-util/rapidsvn
parentStable x86 (diff)
downloadgentoo-2-34da6ce4535c6285ecf97af2cc9d2e3c58d39a7f.tar.gz
gentoo-2-34da6ce4535c6285ecf97af2cc9d2e3c58d39a7f.tar.bz2
gentoo-2-34da6ce4535c6285ecf97af2cc9d2e3c58d39a7f.zip
new version with updated neon support and upstream fixes
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'dev-util/rapidsvn')
-rw-r--r--dev-util/rapidsvn/ChangeLog8
-rw-r--r--dev-util/rapidsvn/files/digest-rapidsvn-0.9.33
-rw-r--r--dev-util/rapidsvn/rapidsvn-0.9.3.ebuild83
3 files changed, 93 insertions, 1 deletions
diff --git a/dev-util/rapidsvn/ChangeLog b/dev-util/rapidsvn/ChangeLog
index 20205791cf2e..b781c9dbb869 100644
--- a/dev-util/rapidsvn/ChangeLog
+++ b/dev-util/rapidsvn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/rapidsvn
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/ChangeLog,v 1.28 2006/07/01 12:08:39 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/ChangeLog,v 1.29 2006/07/05 05:05:04 nerdboy Exp $
+
+*rapidsvn-0.9.3 (05 Jul 2006)
+
+ 05 Jul 2006; Steve Arnold <nerdboy@gentoo.org> +rapidsvn-0.9.3.ebuild:
+ New version with updated neon support (neon version must be in sync with
+ neon DEPEND in subversion) and upstream fixes. Updated bug #134699.
01 Jul 2006; Lars Weiler <pylon@gentoo.org> rapidsvn-0.9.2.ebuild:
Stable on ppc; bug #134699.
diff --git a/dev-util/rapidsvn/files/digest-rapidsvn-0.9.3 b/dev-util/rapidsvn/files/digest-rapidsvn-0.9.3
new file mode 100644
index 000000000000..cb3383742922
--- /dev/null
+++ b/dev-util/rapidsvn/files/digest-rapidsvn-0.9.3
@@ -0,0 +1,3 @@
+MD5 fff420fba3a1d52ff163933ecf1d14e0 rapidsvn-0.9.3.tar.gz 998268
+RMD160 316904503ab1a067fb14b0567d6e28bc2a6ad6c5 rapidsvn-0.9.3.tar.gz 998268
+SHA256 90363935f9a1cb3177d045679db39c94ee44ffc3d67ed63570900ca64771f139 rapidsvn-0.9.3.tar.gz 998268
diff --git a/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild b/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild
new file mode 100644
index 000000000000..351cca9363a8
--- /dev/null
+++ b/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild,v 1.1 2006/07/05 05:05:04 nerdboy Exp $
+
+inherit eutils libtool autotools
+
+DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system."
+HOMEPAGE="http://rapidsvn.tigris.org/"
+SRC_URI="http://www.rapidsvn.org/download/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2.1 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc static"
+
+DEPEND=">=dev-util/subversion-1.3.2-r1
+ >=net-misc/neon-0.26
+ >=x11-libs/wxGTK-2.6.2
+ doc? ( dev-libs/libxslt
+ app-text/docbook-sgml-utils
+ app-doc/doxygen
+ app-text/docbook-xsl-stylesheets )"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A}
+ cd ${S}
+ eautoreconf
+}
+
+src_compile() {
+ einfo "Checking for subversion compiled with neon support..."
+ if built_with_use dev-util/subversion nowebdav; then
+ ewarn "SVN (dev-util/subversion) must be compiled with neon support."
+ einfo "Please re-emerge subversion without the nowebdav USE flag."
+ die "SVN merged with nowebdav USE flag"
+ else
+ einfo "Found neon support; continuing..."
+ fi
+
+ # if you compiled subversion without (the) apache2 (flag) and with the
+ # berkdb flag, you will get an error that it can't find the lib db4
+ # Note: this should be fixed in rapidsvn 0.9.3 and later
+ local myconf
+ local xslss_dir
+
+ if use doc; then
+ xslss_dir=$(ls -1d /usr/share/sgml/docbook/xsl-stylesheets*|head -n1)
+ myconf="--with-docbook-xsl=$xslss_dir"
+ else
+ myconf="--without-xsltproc --without-docbook-xsl \
+ --without-doxygen --without-dot"
+ fi
+ if use static; then
+ myconf="${myconf} --enable-static"
+ else
+ myconf="${myconf} --disable-static --enable-shared"
+ fi
+ # look for wx-config-2.6
+ if (test -x /usr/bin/wx-config-2.6 && `/usr/bin/wx-config-2.6 --toolkit=gtk2 2>/dev/null` ); then
+ myconf="${myconf} --with-wx-config=/usr/bin/wx-config-2.6"
+ else
+ ewarn "wx-config-2.6 not found. Compiling with default wxGTK."
+ fi
+ libtoolize --copy --force
+ elibtoolize --portage
+ econf --with-svn-lib=/usr/$(get_libdir) \
+ --with-svn-include=/usr/include \
+ --with-neon-config=/usr/bin/neon-config \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ doman doc/manpage/rapidsvn.1 || die "doman failed"
+ doicon src/res/bitmaps/svn.xpm
+ make_desktop_entry rapidsvn RapidSVN svn.xpm RevisionControl
+ dodoc HACKING.txt TRANSLATIONS
+ if use doc ; then
+ dodoc AUTHORS CHANGES NEWS README
+ dohtml ${S}/doc/svncpp/html/*
+ fi
+}