summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-06 20:48:30 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-06 20:48:30 +0000
commit07db5d2f7420ed019d2e8f46a65455ed6b5607ee (patch)
tree04f78742c27c563e1372ade369aec14fa0dff9a5 /dev-util/kdevelop-pg-qt
parentFix underlinking, bug 367369 (diff)
downloadgentoo-2-07db5d2f7420ed019d2e8f46a65455ed6b5607ee.tar.gz
gentoo-2-07db5d2f7420ed019d2e8f46a65455ed6b5607ee.tar.bz2
gentoo-2-07db5d2f7420ed019d2e8f46a65455ed6b5607ee.zip
Fix underlinking in tests, bug 370161
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/kdevelop-pg-qt')
-rw-r--r--dev-util/kdevelop-pg-qt/ChangeLog6
-rw-r--r--dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-0.9.5-underlinking.patch29
-rw-r--r--dev-util/kdevelop-pg-qt/kdevelop-pg-qt-0.9.5.ebuild4
3 files changed, 37 insertions, 2 deletions
diff --git a/dev-util/kdevelop-pg-qt/ChangeLog b/dev-util/kdevelop-pg-qt/ChangeLog
index f646371f5679..5bcb3b66be60 100644
--- a/dev-util/kdevelop-pg-qt/ChangeLog
+++ b/dev-util/kdevelop-pg-qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/kdevelop-pg-qt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop-pg-qt/ChangeLog,v 1.3 2011/05/05 14:30:12 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop-pg-qt/ChangeLog,v 1.4 2011/08/06 20:48:30 dilfridge Exp $
+
+ 06 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ kdevelop-pg-qt-0.9.5.ebuild, +files/kdevelop-pg-qt-0.9.5-underlinking.patch:
+ Fix underlinking in tests, bug 370161
*kdevelop-pg-qt-0.9.5 (05 May 2011)
diff --git a/dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-0.9.5-underlinking.patch b/dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-0.9.5-underlinking.patch
new file mode 100644
index 000000000000..b33d94a96dc1
--- /dev/null
+++ b/dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-0.9.5-underlinking.patch
@@ -0,0 +1,29 @@
+diff -ruN kdevelop-pg-qt-0.9.5.orig/tests/CMakeLists.txt kdevelop-pg-qt-0.9.5/tests/CMakeLists.txt
+--- kdevelop-pg-qt-0.9.5.orig/tests/CMakeLists.txt 2011-04-06 00:20:15.000000000 +0200
++++ kdevelop-pg-qt-0.9.5/tests/CMakeLists.txt 2011-08-06 22:46:00.674610229 +0200
+@@ -7,7 +7,7 @@
+ )
+ kde4_add_unit_test(testlocationtable ${testlocationtable_SRCS})
+ target_link_libraries(testlocationtable
+- ${QT_QTTEST_LIBRARY}
++ ${QT_QTCORE_LIBRARY} ${QT_QTTEST_LIBRARY}
+ )
+
+ set(testmemorypool_SRCS
+@@ -15,7 +15,7 @@
+ )
+ kde4_add_unit_test(testmemorypool ${testmemorypool_SRCS})
+ target_link_libraries(testmemorypool
+- ${QT_QTTEST_LIBRARY}
++ ${QT_QTCORE_LIBRARY} ${QT_QTTEST_LIBRARY}
+ )
+
+ set(benchmarks_SRCS
+@@ -23,6 +23,6 @@
+ )
+ kde4_add_unit_test(benchmarks ${benchmarks_SRCS})
+ target_link_libraries(benchmarks
+- ${QT_QTTEST_LIBRARY}
++ ${QT_QTCORE_LIBRARY} ${QT_QTTEST_LIBRARY}
+ )
+
diff --git a/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-0.9.5.ebuild b/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-0.9.5.ebuild
index f1a91923d627..1c670f584774 100644
--- a/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-0.9.5.ebuild
+++ b/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-0.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-0.9.5.ebuild,v 1.1 2011/05/05 14:30:12 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-0.9.5.ebuild,v 1.2 2011/08/06 20:48:30 dilfridge Exp $
EAPI=4
@@ -21,3 +21,5 @@ DEPEND="
sys-devel/bison
sys-devel/flex
"
+
+PATCHES=( "${FILESDIR}/${P}-underlinking.patch" )