summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-26 01:51:54 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-26 01:51:54 +0000
commit99c1fd99cbf5cb930db3e875f87a251303edb0bb (patch)
tree518feb60fd2c44690226af27432c03c094c8763d /dev-util/global
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-99c1fd99cbf5cb930db3e875f87a251303edb0bb.tar.gz
gentoo-2-99c1fd99cbf5cb930db3e875f87a251303edb0bb.tar.bz2
gentoo-2-99c1fd99cbf5cb930db3e875f87a251303edb0bb.zip
Add die following econf for bug 48950
Diffstat (limited to 'dev-util/global')
-rw-r--r--dev-util/global/ChangeLog5
-rw-r--r--dev-util/global/global-4.6.1.ebuild19
2 files changed, 12 insertions, 12 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index 9c3be6325638..a850f372fc70 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/global
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.5 2004/03/13 01:43:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.6 2004/04/26 01:51:54 agriffis Exp $
+
+ 25 Apr 2004; Aron Griffis <agriffis@gentoo.org> global-4.6.1.ebuild:
+ Add die following econf for bug 48950
12 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> global-4.5.3.ebuild,
global-4.5.ebuild, global-4.6.1.ebuild:
diff --git a/dev-util/global/global-4.6.1.ebuild b/dev-util/global/global-4.6.1.ebuild
index 026e40aef740..d8b0a7edd1cc 100644
--- a/dev-util/global/global-4.6.1.ebuild
+++ b/dev-util/global/global-4.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-4.6.1.ebuild,v 1.2 2004/03/13 01:43:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-4.6.1.ebuild,v 1.3 2004/04/26 01:51:54 agriffis Exp $
IUSE="ssl postgres"
@@ -17,20 +17,17 @@ DEPEND=">=sys-libs/glibc-2.2
ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
src_compile() {
+ local myconf
- # Patch configure to add -lssl when using postgresql and ssl
- if [ "`use postgres`" ] && [ "`use ssl`" ]
- then
- sed -i "s/-lcrypt/-lcrypt -lssl/" configure
- fi
-
- myconf=""
- if [ `use postgres` ]; then
+ if use postgres; then
myconf="--with-postgres=/usr"
+ if use ssl; then
+ # Patch configure to add -lssl when using postgresql and ssl
+ sed -i 's/-lcrypt/-lcrypt -lssl/' configure || die 'sed failed'
+ fi
fi
- econf ${myconf} || edie
-
+ econf || die "econf failed"
emake || die
}