summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-05-21 17:15:57 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-05-21 17:15:57 +0000
commitefe3b6c64a4ecd7aa249937f50673f90d2164f49 (patch)
tree3b03d3c7d4bf08cb62338dc7bc94eb47a7dcd7d0 /dev-util/ftnchek/ftnchek-3.2.2.ebuild
parentNew package for old programmers (fortran "lint") (diff)
downloadgentoo-2-efe3b6c64a4ecd7aa249937f50673f90d2164f49.tar.gz
gentoo-2-efe3b6c64a4ecd7aa249937f50673f90d2164f49.tar.bz2
gentoo-2-efe3b6c64a4ecd7aa249937f50673f90d2164f49.zip
New package for old programmers (fortran "lint")
Diffstat (limited to 'dev-util/ftnchek/ftnchek-3.2.2.ebuild')
-rw-r--r--dev-util/ftnchek/ftnchek-3.2.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/ftnchek/ftnchek-3.2.2.ebuild b/dev-util/ftnchek/ftnchek-3.2.2.ebuild
new file mode 100644
index 000000000000..1a8819dafa8a
--- /dev/null
+++ b/dev-util/ftnchek/ftnchek-3.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ftnchek/ftnchek-3.2.2.ebuild,v 1.1 2003/05/21 17:15:53 g2boojum Exp $
+
+DESCRIPTION="Static analyzer a la 'lint' for Fortran 77"
+HOMEPAGE="http://www.dsm.fordham.edu/~ftnchek/"
+SRC_URI="http://www.dsm.fordham.edu/~${PN}/download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+S=${WORKDIR}/${P}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc FAQ INSTALL LICENSE PATCHES README ToDo
+ dohtml html/*
+ dodir /usr/share/${PN}
+ cp -r test ${D}/usr/share/${PN}
+}