summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-05-05 15:13:43 +0000
committerJeroen Roovers <jer@gentoo.org>2013-05-05 15:13:43 +0000
commitdaa4724c23557b07f9ba793ff6d366c929bae52b (patch)
tree812d6b80401912a0e79cb1c1168a1a3642db2ab5 /dev-util/debhelper
parentVersion bump (diff)
downloadgentoo-2-daa4724c23557b07f9ba793ff6d366c929bae52b.tar.gz
gentoo-2-daa4724c23557b07f9ba793ff6d366c929bae52b.tar.bz2
gentoo-2-daa4724c23557b07f9ba793ff6d366c929bae52b.zip
Remove IUSE=nls as it is a duplicate of each lingua.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util/debhelper')
-rw-r--r--dev-util/debhelper/ChangeLog5
-rw-r--r--dev-util/debhelper/debhelper-9.20130504.ebuild57
2 files changed, 32 insertions, 30 deletions
diff --git a/dev-util/debhelper/ChangeLog b/dev-util/debhelper/ChangeLog
index e51bc7f59f9b..51144b342785 100644
--- a/dev-util/debhelper/ChangeLog
+++ b/dev-util/debhelper/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/debhelper
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/ChangeLog,v 1.67 2013/05/05 14:08:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/ChangeLog,v 1.68 2013/05/05 15:13:43 jer Exp $
+
+ 05 May 2013; Jeroen Roovers <jer@gentoo.org> debhelper-9.20130504.ebuild:
+ Remove IUSE=nls as it is a duplicate of each lingua.
*debhelper-9.20130504 (05 May 2013)
diff --git a/dev-util/debhelper/debhelper-9.20130504.ebuild b/dev-util/debhelper/debhelper-9.20130504.ebuild
index ee90401b7988..5b082d0421af 100644
--- a/dev-util/debhelper/debhelper-9.20130504.ebuild
+++ b/dev-util/debhelper/debhelper-9.20130504.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/debhelper-9.20130504.ebuild,v 1.1 2013/05/05 14:08:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/debhelper-9.20130504.ebuild,v 1.2 2013/05/05 15:13:43 jer Exp $
EAPI=5
inherit eutils toolchain-funcs
@@ -12,10 +12,14 @@ SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls test"
+IUSE="test"
DH_LINGUAS=( de es fr )
IUSE+=" ${DH_LINGUAS[@]/#/linguas_}"
+NLS_DEPEND=$(
+ printf "linguas_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LINGUAS[@]}
+)
+
RDEPEND="
>=dev-lang/perl-5.10
app-arch/dpkg
@@ -23,7 +27,7 @@ RDEPEND="
virtual/perl-Getopt-Long
"
DEPEND="${RDEPEND}
- nls? ( >=app-text/po4a-0.24 )
+ ${NLS_DEPEND}
test? ( dev-perl/Test-Pod )
"
@@ -32,17 +36,15 @@ S=${WORKDIR}/${PN}
src_compile() {
tc-export CC
- if use nls; then
- local LANGS="" lingua
- for lingua in ${DH_LINGUAS[@]}; do
- use linguas_${lingua} && LANGS+=" ${lingua}"
- done
- fi
+ local LANGS="" USE_NLS=no lingua
+ for lingua in ${DH_LINGUAS[@]}; do
+ if use linguas_${lingua}; then
+ LANGS+=" ${lingua}"
+ USE_NLS=yes
+ fi
+ done
- emake \
- USE_NLS=$(usex nls) \
- LANGS="${LANGS}" \
- build
+ emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build
}
src_install() {
@@ -50,22 +52,19 @@ src_install() {
dodoc doc/* debian/changelog
docinto examples
dodoc examples/*
+ local lingua
for manfile in *.1 *.7 ; do
- case ${manfile} in
- *.de.?) use linguas_de \
- && cp ${manfile} "${T}"/${manfile/.de/} \
- && doman -i18n=de "${T}"/${manfile/.de/}
- ;;
- *.es.?) use linguas_es \
- && cp ${manfile} "${T}"/${manfile/.es/} \
- && doman -i18n=es "${T}"/${manfile/.es/}
- ;;
- *.fr.?) use linguas_fr \
- && cp ${manfile} "${T}"/${manfile/.fr/} \
- && doman -i18n=fr "${T}"/${manfile/.fr/}
- ;;
- *) doman ${manfile}
- ;;
- esac
+ for lingua in ${DH_LINGUAS[@]}; do
+ case ${manfile} in
+ *.${lingua}.?)
+ use linguas_${lingua} \
+ && cp ${manfile} "${T}"/${manfile/.${lingua}/} \
+ && doman -i18n=${lingua} "${T}"/${manfile/.${lingua}/}
+ ;;
+ *)
+ doman ${manfile}
+ ;;
+ esac
+ done
done
}