summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-04-25 11:43:05 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-04-25 11:43:05 +0000
commitcd4e8f354141f18780d7c2139ba13d34df785f94 (patch)
tree4218d48d7ed081a4bd038788c85b93b5a191223b /dev-util/cvsgraph/cvsgraph-1.5.1.ebuild
parentstabilise on x86 (diff)
downloadgentoo-2-cd4e8f354141f18780d7c2139ba13d34df785f94.tar.gz
gentoo-2-cd4e8f354141f18780d7c2139ba13d34df785f94.tar.bz2
gentoo-2-cd4e8f354141f18780d7c2139ba13d34df785f94.zip
Version bump; added metadata.xml for cvs-utils herd.
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'dev-util/cvsgraph/cvsgraph-1.5.1.ebuild')
-rw-r--r--dev-util/cvsgraph/cvsgraph-1.5.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/cvsgraph/cvsgraph-1.5.1.ebuild b/dev-util/cvsgraph/cvsgraph-1.5.1.ebuild
new file mode 100644
index 000000000000..326b02dd7ce2
--- /dev/null
+++ b/dev-util/cvsgraph/cvsgraph-1.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsgraph/cvsgraph-1.5.1.ebuild,v 1.1 2005/04/25 11:43:05 ka0ttic Exp $
+
+DESCRIPTION="CVS/RCS repository grapher"
+HOMEPAGE="http://www.akhphd.au.dk/~bertho/cvsgraph"
+SRC_URI="http://www.akhphd.au.dk/~bertho/cvsgraph/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc -alpha -amd64 -ia64"
+IUSE="gif jpeg nls png truetype zlib"
+
+DEPEND="media-libs/gd
+ zlib? ( sys-libs/zlib )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ truetype? ( media-libs/freetype )"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable gif) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable truetype) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin cvsgraph
+ insinto /etc
+ doins cvsgraph.conf
+ doman cvsgraph.1 cvsgraph.conf.5
+ dodoc ChangeLog README contrib/*.php3
+}