summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-02-07 03:28:21 +0000
committerMichael Weber <xmw@gentoo.org>2012-02-07 03:28:21 +0000
commit095262fc65d13ca9bef7d22c4a4bc7c0dc480fb4 (patch)
treea96e0265bb0ad91b27bc1c8e4fae4a480dbb5b4c /dev-util/cppcheck
parentAdded myself as maintainer, bug #365077 (diff)
downloadgentoo-2-095262fc65d13ca9bef7d22c4a4bc7c0dc480fb4.tar.gz
gentoo-2-095262fc65d13ca9bef7d22c4a4bc7c0dc480fb4.tar.bz2
gentoo-2-095262fc65d13ca9bef7d22c4a4bc7c0dc480fb4.zip
Version bump (thanks Jaak Ristioja, bug 402289)
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog9
-rw-r--r--dev-util/cppcheck/cppcheck-1.52.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index 037ae120d417..d85297f9d1c1 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cppcheck
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.28 2011/11/10 23:58:52 xmw Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.29 2012/02/07 03:28:21 xmw Exp $
+
+*cppcheck-1.52 (07 Feb 2012)
+
+ 07 Feb 2012; Michael Weber <xmw@gentoo.org> +cppcheck-1.52.ebuild:
+ Version bump (thanks Jaak Ristioja, bug 402289)
10 Nov 2011; Michael Weber <xmw@gentoo.org> -cppcheck-1.48.ebuild,
-cppcheck-1.49.ebuild, -cppcheck-1.50.ebuild:
diff --git a/dev-util/cppcheck/cppcheck-1.52.ebuild b/dev-util/cppcheck/cppcheck-1.52.ebuild
new file mode 100644
index 000000000000..ef2a1bec21c5
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.52.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.52.ebuild,v 1.1 2012/02/07 03:28:20 xmw Exp $
+
+EAPI="3"
+PYTHON_DEPEND="htmlreport? 2"
+
+inherit distutils eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+DEPEND="htmlreport? ( dev-python/pygments )
+ qt4? ( x11-libs/qt-gui:4
+ x11-libs/qt-assistant:4 )"
+RDEPEND="${DEPEND}"
+
+DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
+
+pkg_setup() {
+ if use htmlreport ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if use htmlreport ; then
+ pushd htmlreport
+ python_convert_shebangs -r 2 .
+ distutils_src_prepare
+ popd
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake || die
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ use htmlreport && distutils_src_compile
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc readme.txt || die
+ if use qt4 ; then
+ dobin gui/${PN}-gui || die
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
+ fi
+ use htmlreport && distutils_src_install
+}
+
+pkg_postinst() {
+ use htmlreport && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use htmlreport && distutils_pkg_postrm
+}