summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-10-20 05:53:31 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-10-20 05:53:31 +0000
commit8f70e23d71d6ec0ebef88895cb7f0f647dfc6144 (patch)
tree86d20907d30e009245e494a517e8185be1415349 /dev-util/build/build-0.3.8.ebuild
parentMarked ~hppa (bug #341149). (diff)
downloadgentoo-2-8f70e23d71d6ec0ebef88895cb7f0f647dfc6144.tar.gz
gentoo-2-8f70e23d71d6ec0ebef88895cb7f0f647dfc6144.tar.bz2
gentoo-2-8f70e23d71d6ec0ebef88895cb7f0f647dfc6144.zip
Initial commit (ebuild written by me), needed for xsd and the required libraries.
(Portage version: 2.2_rc94/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/build/build-0.3.8.ebuild')
-rw-r--r--dev-util/build/build-0.3.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/build/build-0.3.8.ebuild b/dev-util/build/build-0.3.8.ebuild
new file mode 100644
index 000000000000..a534ba2ccf71
--- /dev/null
+++ b/dev-util/build/build-0.3.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/build/build-0.3.8.ebuild,v 1.1 2010/10/20 05:53:31 dev-zero Exp $
+
+inherit versionator
+
+DESCRIPTION="A massively-parallel software build system implemented on top of GNU make."
+HOMEPAGE="http://kolpackov.net/projects/build/"
+SLOT="$(get_version_component_range 1-2)"
+SRC_URI="http://www.codesynthesis.com/download/${PN}/${SLOT}/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ emake install_prefix="${D}/usr" install || die "emake install failed"
+
+ dodoc NEWS README documentation/[[:upper:]]*
+ dohtml -A xhtml documentation/*.{css,xhtml}
+
+ if use examples ; then
+ # preserving symlinks in the examples
+ cp -dpR examples "${D}/usr/share/doc/${PF}"
+ fi
+}