summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-03-31 17:03:36 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-03-31 17:03:36 +0000
commit9a2e939ce810f79964fc466e78cc99baa9e7a246 (patch)
treea3fef140e84db7d266c31067eb46c96a07c81f0a /dev-util/bitkeeper
parentfix bug 16853 (diff)
downloadgentoo-2-9a2e939ce810f79964fc466e78cc99baa9e7a246.tar.gz
gentoo-2-9a2e939ce810f79964fc466e78cc99baa9e7a246.tar.bz2
gentoo-2-9a2e939ce810f79964fc466e78cc99baa9e7a246.zip
Solves name conflicts between BK man pages and system man pages; also includes
Diffstat (limited to 'dev-util/bitkeeper')
-rw-r--r--dev-util/bitkeeper/ChangeLog9
-rw-r--r--dev-util/bitkeeper/bitkeeper-3.0.1-r1.ebuild93
-rw-r--r--dev-util/bitkeeper/files/digest-bitkeeper-3.0.1-r16
3 files changed, 107 insertions, 1 deletions
diff --git a/dev-util/bitkeeper/ChangeLog b/dev-util/bitkeeper/ChangeLog
index 46577bb7a5b3..7a544921f5e2 100644
--- a/dev-util/bitkeeper/ChangeLog
+++ b/dev-util/bitkeeper/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/bitkeeper
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.7 2003/02/17 04:05:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.8 2003/03/31 17:03:36 mholzer Exp $
+
+*bitkeeper-3.0.1-r1 (31 Mar 2003)
+
+ 31 Mar 2003; Martin Holzer <mholzer@gentoo.org> bitkeeper-3.0.1-r1.ebuild:
+ Solves name conflicts between BK man pages and system man pages; also includes
+ code to restore hard links broken by prepman. Patch was submitted in #14409 by
+ Evan Powers (powers.161@osu.edu).
*bitkeeper-3.0.1 (18 Jan 2003)
diff --git a/dev-util/bitkeeper/bitkeeper-3.0.1-r1.ebuild b/dev-util/bitkeeper/bitkeeper-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..a03b9fe213b5
--- /dev/null
+++ b/dev-util/bitkeeper/bitkeeper-3.0.1-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.0.1-r1.ebuild,v 1.1 2003/03/31 17:03:36 mholzer Exp $
+
+DESCRIPTION="A scalable configuration management system."
+HOMEPAGE="http://www.bitkeeper.com/"
+SRC_URI="x86? ( bk-3.0.1-x86-glibc22-linux.bin )
+ ppc? ( bk-3.0.1-powerpc-glibc21-linux.bin )
+ sparc? ( bk-3.0.1-sparc-glibc21-linux.bin )
+ alpha? ( bk-3.0.1-alpha-glibc21-linux.bin )
+ arm? ( bk-3.0.1-arm-glibc21-linux.bin )
+ hppa? ( bk-3.0.1-hppa-glibc22-linux.bin )"
+
+SLOT="0"
+LICENSE="BKL"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa"
+IUSE="X"
+
+# binary package, so no DEPENDs; X optional in RDEPENDs
+DEPEND=""
+RDEPEND="x86? ( >=virtual/glibc-2.2 )
+ ppc? ( >=virtual/glibc-2.1 )
+ sparc? ( >=virtual/glibc-2.1 )
+ alpha? ( >=virtual/glibc-2.1 )
+ arm? ( >=virtual/glibc-2.1 )
+ hppa? ( >=virtual/glibc-2.2 )
+ >=dev-lang/tcl-8.3.3
+ X? ( >=dev-lang/tk-8.3.3 )"
+
+RESTRICT="fetch"
+
+S=${WORKDIR}/bitkeeper
+
+pkg_nofetch() {
+ eerror "You need to perform the following steps to install this package:"
+ eerror " - Sign up at ${HOMEPAGE}"
+ eerror " - Check your email and visit the download location"
+ eerror " - Download ${A} and place it in ${DISTDIR}"
+ eerror " - emerge this package again"
+ eerror "Run 'bk regression' to verify the installation. (Recommended)"
+}
+
+pkg_setup() {
+ cd ${T}
+ cp ${DISTDIR}/${A} .
+ chmod 755 ${A}
+ echo 'none' | ./${A} > output 2>/dev/null
+ installer=`sed -n -e "s/Installation script: \(.*\)/\1/p" output`
+ archive=`sed -n -e "s/Gzipped tar archive: \(.*\)/\1/p" output`
+ mv $archive ${T}/archive
+}
+
+src_unpack() {
+ tar -vxzpf ${T}/archive
+ chown -R root:root ${S}
+ chmod -R u+w,go-w ${S}
+}
+
+src_install() {
+ dodir /opt /etc/env.d /usr/share/man/man1
+
+ mv ${S} ${D}/opt/${P} && cd ${D}
+
+ # BK includes two copies of most man pages; the second copy is a
+ # hard link to the first with its filename prefixed with
+ # 'bk-'. 'prepman' breaks these hard links, so use a
+ # workaround. Furthermore, we want only the 'bk-' versions to be
+ # in ${MANPATH} since there are naming conflicts, so install
+ # symlinks into /usr/share/man. (For example BK includes a
+ # less-detailed man page for grep which would override the
+ # /usr/share/man version.)
+
+ prepman /opt/${P}
+
+ find opt/${P}/man -iname 'bk-*' -printf '
+ F=`echo %f|sed -e "s/bk-//"`
+ rm -f %h/$F
+ dohard /%h/%f /%h/$F
+ dosym /%h/%f /usr/share/man/%P' >${T}/links.sh
+ . ${T}/links.sh
+
+ dosym /opt/${P}/man/man1/bk.1.gz /usr/share/man/man1/bk.1.gz
+
+ cat <<-EOF >${D}/etc/env.d/10bitkeeper
+ # Generated by ${PF} ebuild
+ PATH=/opt/${P}
+ ROOTPATH=/opt/${P}
+ EOF
+}
+
+pkg_postinst() {
+ einfo "Run 'bk regression' to verify the installation. (Recommended)"
+}
diff --git a/dev-util/bitkeeper/files/digest-bitkeeper-3.0.1-r1 b/dev-util/bitkeeper/files/digest-bitkeeper-3.0.1-r1
new file mode 100644
index 000000000000..9fffe1deae45
--- /dev/null
+++ b/dev-util/bitkeeper/files/digest-bitkeeper-3.0.1-r1
@@ -0,0 +1,6 @@
+MD5 9fb61b5a96a08b3c8066dacb0c20c09d bk-3.0.1-x86-glibc22-linux.bin 1850216
+MD5 10524bb1ff6bc147c983e1530f56d3d8 bk-3.0.1-powerpc-glibc21-linux.bin 2081820
+MD5 c914b595724050a7a0277ea264075ebf bk-3.0.1-sparc-glibc21-linux.bin 2027024
+MD5 5297a4150cce96abce58d243db1b8b5f bk-3.0.1-alpha-glibc21-linux.bin 2791728
+MD5 9c077d7f614092908acffc5347864e63 bk-3.0.1-arm-glibc21-linux.bin 1987560
+MD5 55f6b8d18739563bbc7d1095270e5b32 bk-3.0.1-hppa-glibc22-linux.bin 2060236